summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch')
-rw-r--r--x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch92
1 files changed, 92 insertions, 0 deletions
diff --git a/x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch b/x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch
new file mode 100644
index 000000000000..47efa7132f99
--- /dev/null
+++ b/x11-misc/bbpager/files/bbpager-0.4.7-as-needed.patch
@@ -0,0 +1,92 @@
+diff -NrU5 bbpager-0.4.7.orig/configure.ac bbpager-0.4.7/configure.ac
+--- bbpager-0.4.7.orig/configure.ac 2008-12-20 22:38:36.000000000 +0100
++++ bbpager-0.4.7/configure.ac 2008-12-20 23:58:12.000000000 +0100
+@@ -37,40 +37,45 @@
+ AC_PROG_INSTALL
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(ctype.h fcntl.h libgen.h locale.h process.h signal.h stdio.h time.h unistd.h sys/param.h sys/select.h sys/stat.h sys/time.h sys/types.h sys/wait.h)
+ AC_HEADER_TIME
+
++dnl Checks for typedefs, structures, and compiler characteristics.
++AC_C_CONST
++AC_STRUCT_TM
++
++dnl Checks for library functions.
++AC_CHECK_FUNCS(select strstr)
++
+ AC_CHECK_FUNCS(setlocale sigaction strftime)
+
+ AC_PATH_X
+ AC_PATH_XTRA
+
+-CFLAGS="$CFLAGS $X_CFLAGS"
+-CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
+- AC_MSG_ERROR(XOpenDisplay not found in -lX11))
++AC_CHECK_LIB([X11],
++ [XOpenDisplay],
++ [],
++ [AC_MSG_ERROR(XOpenDisplay not found in -lX11)]
++ )
+
+ dnl Checks for Xextension
+-SHAPE=
+-AC_CHECK_LIB(Xext, XMissingExtension, LIBS="$LIBS -lXext"; SHAPE="-DSHAPE",
+- AC_MSG_ERROR(XMissingExtension not found in -lXext))
+-AC_SUBST(SHAPE)
+-
+-dnl Checks for typedefs, structures, and compiler characteristics.
+-AC_C_CONST
+-AC_HEADER_TIME
+-AC_STRUCT_TM
+-
+-dnl Checks for library functions.
+-AC_CHECK_FUNCS(select strstr)
++PKG_CHECK_MODULES([XEXT], [xext],
++ [
++ AC_CHECK_LIB([Xext],
++ [XMissingExtension],
++ [],
++ [AC_MSG_ERROR(XMissingExtension not found in -lXext)]
++ )
++ ],
++ [AC_MSG_ERROR(xext not found)]
++ )
+
+ dnl pkgconfig checks for blackbox library
+ PKG_CHECK_MODULES(LIBBT, libbt)
+-CXXFLAGS="$CXXFLAGS $LIBBT_CFLAGS"
+-LIBS="$LIBS $LIBBT_LIBS"
++
++LIBS="$LIBS $LIBBT_LIBS $X_LIBS $X_PRE_LIBS $XEXT_LIBS"
+
+ dnl generate the config header
+ AM_CONFIG_HEADER(config.h)
+
+ dnl Print results
+diff -NrU5 bbpager-0.4.7.orig/src/Makefile.am bbpager-0.4.7/src/Makefile.am
+--- bbpager-0.4.7.orig/src/Makefile.am 2008-12-20 22:38:36.000000000 +0100
++++ bbpager-0.4.7/src/Makefile.am 2008-12-20 23:56:15.000000000 +0100
+@@ -1,8 +1,9 @@
+-CPPFLAGS = @CPPFLAGS@ @SHAPE@ \
++AM_CPPFLAGS = $(CPPFLAGS) -DSHAPE \
+ -DBBTOOL_GLOBAL=\"$(datadir)/bbtools/bbpager.rc\" \
+ -DBBTOOL_LOCAL=\"~/.bbtools/bbpager.rc\"
++AM_CXXFLAGS = $(X_CFLAGS) $(XEXT_CFLAGS) $(LIBBT_CFLAGS)
+
+ bin_PROGRAMS = bbpager
+ bbpager_SOURCES = bbpager.cxx bbpager.h \
+ main.cxx main.h \
+ Baseresource.cxx Baseresource.h \
+@@ -10,7 +11,8 @@
+ wminterface.cxx wminterface.h \
+ blackboxstyle.h \
+ pager.cxx pager.h \
+ desktop.cxx desktop.h
+ # pagermenu.cc pagermenu.hh \
+-bbpager_LDADD = @X_LIBS@
++#
++
+