summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:57:02 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:20 +0100
commit2ab2541fd0e2cbf6cb48af797564be75052a8d98 (patch)
tree2224c7d007abb995c0d67b6584ed49579bc6c0bb /x11-misc/bbrun
parentx11-misc/apwal: respect PKG_CONFIG (diff)
downloadgentoo-2ab2541fd0e2cbf6cb48af797564be75052a8d98.tar.gz
gentoo-2ab2541fd0e2cbf6cb48af797564be75052a8d98.tar.bz2
gentoo-2ab2541fd0e2cbf6cb48af797564be75052a8d98.zip
x11-misc/bbrun: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/bbrun')
-rw-r--r--x11-misc/bbrun/bbrun-1.6-r1.ebuild2
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-makefile.patch4
2 files changed, 4 insertions, 2 deletions
diff --git a/x11-misc/bbrun/bbrun-1.6-r1.ebuild b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
index 27c12b7c8678..a6a1b752e378 100644
--- a/x11-misc/bbrun/bbrun-1.6-r1.ebuild
+++ b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
@@ -35,6 +35,8 @@ src_prepare() {
}
src_compile() {
+ tc-export PKG_CONFIG
+
emake -C ${PN} CC="$(tc-getCC)"
}
diff --git a/x11-misc/bbrun/files/bbrun-1.6-makefile.patch b/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
index 21e855746d09..c33a0f44d21c 100644
--- a/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
+++ b/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
@@ -9,8 +9,8 @@ http://bugs.gentoo.org/367853
LIBDIR = -L/usr/lib -L/usr/X11R6/lib
-LIBS = -lXpm `pkg-config --libs gtk+-2.0`
-CFLAGS = `pkg-config --cflags gtk+-2.0`
-+LIBS = `pkg-config --libs xext xpm gtk+-2.0`
-+DEP_CFLAGS = `pkg-config --cflags xext xpm gtk+-2.0`
++LIBS = `${PKG_CONFIG} --libs xext xpm gtk+-2.0`
++DEP_CFLAGS = `${PKG_CONFIG} --cflags xext xpm gtk+-2.0`
OBJS = bbrun.o \
../wmgeneral/wmgeneral.o \