summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbweather
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbweather')
-rw-r--r--x11-misc/bbweather/Manifest1
-rw-r--r--x11-misc/bbweather/bbweather-0.6.3-r1.ebuild45
-rw-r--r--x11-misc/bbweather/files/bbweather-asneeded.patch40
-rw-r--r--x11-misc/bbweather/metadata.xml8
4 files changed, 94 insertions, 0 deletions
diff --git a/x11-misc/bbweather/Manifest b/x11-misc/bbweather/Manifest
new file mode 100644
index 000000000000..8bd2c146d787
--- /dev/null
+++ b/x11-misc/bbweather/Manifest
@@ -0,0 +1 @@
+DIST bbweather-0.6.3.tar.bz2 80631 SHA256 575e0f5dd1af770490bf0f3ef9c26de5245deb91f79caa3d5db3cd9dc23b8e1e SHA512 e5bd4febf119c0f81a64fb5ff4cf3b526a84e8fd26005ff04c6297f9b50963d2d710227469f9a1cf2d1c51f3524a2bce544a07c70ca4e5beff64c954768468a6 WHIRLPOOL 7b0c2f4561f54bdf1daab217ca4ca3d26e44a377013f327668a5edeb964f189ea19f1eb413ca48f35c52e69275ed945e8843c1dfedf59b28b5dc3cacd35c5724
diff --git a/x11-misc/bbweather/bbweather-0.6.3-r1.ebuild b/x11-misc/bbweather/bbweather-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..c1586ad261a1
--- /dev/null
+++ b/x11-misc/bbweather/bbweather-0.6.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="blackbox weather monitor"
+HOMEPAGE="http://www.netmeister.org/apps/bbweather/"
+SRC_URI="http://www.netmeister.org/apps/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ x11-libs/libX11"
+RDEPEND="${DEPEND}
+ net-misc/wget
+ x11-apps/xmessage
+ !<=x11-plugins/gkrellweather-2.0.7-r1"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-asneeded.patch
+ gunzip doc/*.gz || die
+ sed -i \
+ -e "s:man_DATA:man1_MANS:;s:.gz::g;/^mandir/d" \
+ doc/Makefile.am || die
+ sed -i \
+ -e 's|-helvetica-|-*-|g' \
+ resource.cpp data/${PN}.{nobb,style} || die
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install || die
+ dodoc README AUTHORS ChangeLog NEWS TODO data/README.bbweather || die
+
+ # since multiple bbtools packages provide this file, install
+ # it in /usr/share/doc/${PF}
+ mv "${D}"/usr/share/bbtools/bbtoolsrc.in \
+ "${D}"/usr/share/doc/${PF}/bbtoolsrc.example
+}
diff --git a/x11-misc/bbweather/files/bbweather-asneeded.patch b/x11-misc/bbweather/files/bbweather-asneeded.patch
new file mode 100644
index 000000000000..593e471641c8
--- /dev/null
+++ b/x11-misc/bbweather/files/bbweather-asneeded.patch
@@ -0,0 +1,40 @@
+Fixing build with as-needed
+
+https://bugs.gentoo.org/248556
+
+--- configure.in
++++ configure.in
+@@ -56,15 +56,10 @@
+ AC_PATH_X
+ AC_PATH_XTRA
+
+-CFLAGS="$CFLAGS $X_CFLAGS"
+-CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
+ DATADIR=$datadir
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
+- AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+-
+-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
++AC_CHECK_LIB([X11], [XOpenDisplay], ,
++ AC_MSG_ERROR(XOpenDisplay not found in -lX11), )
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+--- Makefile.am
++++ Makefile.am
+@@ -1,5 +1,4 @@
+-CPPFLAGS = @CPPFLAGS@ \
+- -DDEFAULT_CONF=\"$(datadir)/bbtools/bbweather.conf\" \
++AM_CPPFLAGS = -DDEFAULT_CONF=\"$(datadir)/bbtools/bbweather.conf\" \
+ -DDEFAULT_NOBB=\"$(datadir)/bbtools/bbweather.nobb\"
+
+
+@@ -13,4 +12,5 @@
+ Basewindow.cpp Basewindow.h \
+ blackboxstyle.h
+ EXTRA_DIST = BUGS TODO
+-bbweather_LDADD = @X_LIBS@
++bbweather_LDADD = @X_PRE_LIBS@ @X_LIBS@ @X_EXTRA_LIBS@
++bbweather_CFLAGS = @X_PRE_CFLAGS@ @X_CFLAGS@ @X_EXTRA_CFLAGS@
diff --git a/x11-misc/bbweather/metadata.xml b/x11-misc/bbweather/metadata.xml
new file mode 100644
index 000000000000..2391229f31bf
--- /dev/null
+++ b/x11-misc/bbweather/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ Weather monitor for Blackbox.
+ </longdescription>
+</pkgmetadata>