summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/calise/calise-0.4.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/calise/calise-0.4.2.ebuild')
-rw-r--r--x11-misc/calise/calise-0.4.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/calise/calise-0.4.2.ebuild b/x11-misc/calise/calise-0.4.2.ebuild
new file mode 100644
index 000000000000..9553d4f3b515
--- /dev/null
+++ b/x11-misc/calise/calise-0.4.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 linux-info systemd
+
+DESCRIPTION="Computes ambient brightness and sets screen's correct backlight using a webcam"
+HOMEPAGE="http://calise.sourceforge.net/"
+SRC_URI="http://sourceforge.net/projects/${PN}/files/${PN}-beta/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="${RDEPEND}
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ sci-astronomy/pyephem[${PYTHON_USEDEP}]
+ x11-themes/hicolor-icon-theme"
+DEPEND="${CDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+ sys-kernel/linux-headers
+ x11-libs/libX11"
+RDEPEND="${CDEPEND}"
+
+CONFIG_CHECK="~BACKLIGHT_CLASS_DEVICE"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Add missing trailing ; to desktop file.
+ sed -i 's/^\(Categories=Utility\)$/\1;/' \
+ share/applications/calise.desktop.in || die
+
+ # Fix up bashisms.
+ sed -i 's:&>/dev/null:2>\&1 >/dev/null:' \
+ other/init_scripts/init.d/${PN}d || die
+}
+
+src_install() {
+ doconfd other/init_scripts/conf.d/${PN}d
+ doinitd other/init_scripts/init.d/${PN}d
+ systemd_dounit other/systemd_scripts/${PN}d.service
+
+ install -D -m755 other/pm-utils_scripts/53${PN}d "${D}"/usr/lib/pm-utils/sleep.d/53${PN}d
+
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ einfo "Optional runtime dependency: dev-python/PyQt4 for GUI"
+}