summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-08 07:00:04 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-08 17:16:05 +0200
commit5a257242158d5067022f92c7e4b5d22a511b3552 (patch)
treeb14c70660533d254725e89459098b8eba35bbfac /x11-misc/cbatticon
parentnet-analyzer/wireshark: IUSE=nghttp2 => IUSE=http2 (diff)
downloadgentoo-5a257242158d5067022f92c7e4b5d22a511b3552.tar.gz
gentoo-5a257242158d5067022f92c7e4b5d22a511b3552.tar.bz2
gentoo-5a257242158d5067022f92c7e4b5d22a511b3552.zip
x11-misc/cbatticon: Version 1.6.10
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/cbatticon')
-rw-r--r--x11-misc/cbatticon/Manifest1
-rw-r--r--x11-misc/cbatticon/cbatticon-1.6.10.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/cbatticon/Manifest b/x11-misc/cbatticon/Manifest
index f80cb1752520..f4fb8fbf3cd5 100644
--- a/x11-misc/cbatticon/Manifest
+++ b/x11-misc/cbatticon/Manifest
@@ -1,3 +1,4 @@
+DIST cbatticon-1.6.10.tar.gz 32402 BLAKE2B 91ba6eb581b4cd0b31ae5a49b12970fc7d02d1ba790bffc80886c05ad2b0573ee1aca479d90591498dd6d816bb7e24bee6918e5a8fa8823cf376a3a3da598993 SHA512 cf499eb7ac1d775918a7af01700a9e8eeefd9e31a44fd63c9f38bff83945cea9fb21dde960052768f8d0a0c004caeea115f2d80cb3838789859d43e432eae055
DIST cbatticon-1.6.5.tar.gz 27951 BLAKE2B 41d43bd7bfd5741e37365bed1541c88e255998a4ba69143f80a9c59ac4f51c280b7d07f3f9aba95063a8c3779c9637f7b4e27b771fade0e6092215b529813bd7 SHA512 5e1648cf3b31fe42aefd0a5e79c4e5dc22c3ce4b6f594f0933229494ca6f2e28e44a7e078ef839de1df0b8c1ba494fce8a58866ad70d056799320f4dea32713b
DIST cbatticon-1.6.7.tar.gz 30086 BLAKE2B 460f185688e7aa8eec3f075454440705e1b6989ae9640f026f17c50511518ae181901e69efd987a879eabad47df5725c444bee9973e2faaa2d78775d2f6d83a9 SHA512 730d1be1350ba9b906f438c58c4e3172c4041d0e7c73ffbd91cbe5a01688e400bb9a7d89ccd86bff658afc803776dd5691323c720e6d41b1b1e3aeb58707f6e9
DIST cbatticon-1.6.8.tar.gz 31185 BLAKE2B d8d7d2fe13764bf4b9c091eaebb8bd90b2daeeb10a2093c3b3724c5009a5f56e55788e0390cc81ad2e5c50937f8348bbee74d32f0768a15114a22ad9e02756ab SHA512 61d6f64cc57672f672869f8eb3b5ccb8f95dfdaa0b6eb1e91c824e22e4aba195cc164aab0b0353599c1c1a07f6d00a7a2f177829a15534c96a4e24e4cdfd0986
diff --git a/x11-misc/cbatticon/cbatticon-1.6.10.ebuild b/x11-misc/cbatticon/cbatticon-1.6.10.ebuild
new file mode 100644
index 000000000000..c50d042f8226
--- /dev/null
+++ b/x11-misc/cbatticon/cbatticon-1.6.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A lightweight and fast battery icon that sits in your system tray"
+HOMEPAGE="https://github.com/ColinJones/cbatticon"
+SRC_URI="https://github.com/ColinJones/cbatticon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ strip-linguas -i .
+}
+
+src_compile() {
+ tc-export CC
+ emake \
+ $(usex libnotify WITH_NOTIFY=1 WITH_NOTIFY=0) \
+ V=1 \
+ VERSION="${PF}" \
+ WITH_GTK3=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ DOCDIR="/usr/share/doc/${PF}" \
+ LANGUAGES="${LINGUAS}" \
+ V=1 VERSION="${PF}" \
+ install
+
+ dodoc Changelog
+}