summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/cdm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/cdm')
-rw-r--r--x11-misc/cdm/Manifest2
-rw-r--r--x11-misc/cdm/cdm-0.5.3.ebuild75
-rw-r--r--x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild71
-rw-r--r--x11-misc/cdm/files/cdm-0.5.3-invalid-MIT-cookie.patch19
-rw-r--r--x11-misc/cdm/metadata.xml19
5 files changed, 186 insertions, 0 deletions
diff --git a/x11-misc/cdm/Manifest b/x11-misc/cdm/Manifest
new file mode 100644
index 000000000000..53066f7e3a42
--- /dev/null
+++ b/x11-misc/cdm/Manifest
@@ -0,0 +1,2 @@
+DIST cdm-0.5.3.tar.gz 13751 SHA256 fb9ada13d3416305828c99943698fe7df3b0ab91bd6099e7b2707e1d8dd99a23 SHA512 bdb2746c41272d47defd6fcae3ab18bc71de6aaca521d8deee82d776fe1c06ea0eb679297dc731e9ecf878bee400aabccdb3d6d044f2ffcdc5e838488b0d6799 WHIRLPOOL 90265c475acc5a41e796cef9afb2087437885ca4b52f02e908d08f4e6f78201f1d09afeb0ebf906a6b3dcf3c7be69f9d5372d3035f85ed7d090137ce70bb8dc3
+DIST cdm-0.6.1_pre20130419.tar.gz 16056 SHA256 3fabec053271c39bbca44074fd05eda0ccf8c1e320664bb6d8f23fa79aca2bca SHA512 638d92c536609b8bf1d08f4be80933e5ff23acfe412ee6b72ff924edbe1e510110b7941caea9b206136ee5a75dddd998275e89c132feba0ed3df26ab1657bf8b WHIRLPOOL 5606bc125080c74b5b49aebc26283817e03ef84bff5e671fa7df9f3f8041c3975db34a2a00ad37578419319244dc66935908df9bdd8b19f6d4b9351e5ff11f50
diff --git a/x11-misc/cdm/cdm-0.5.3.ebuild b/x11-misc/cdm/cdm-0.5.3.ebuild
new file mode 100644
index 000000000000..4d5474af85eb
--- /dev/null
+++ b/x11-misc/cdm/cdm-0.5.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base pam eutils
+
+DESCRIPTION="The Console Display Manager"
+HOMEPAGE="https://wiki.archlinux.org/index.php/CDM"
+SRC_URI="http://dev.gentoo.org/~gienah/snapshots/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam consolekit"
+REQUIRED_USE="consolekit? ( pam )"
+
+DEPEND="app-shells/bash"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog
+ x11-apps/xdpyinfo
+ x11-apps/xinit
+ consolekit? ( sys-auth/consolekit
+ sys-apps/dbus )
+ pam? ( virtual/pam )"
+
+PATCHES=("${FILESDIR}/${PN}-0.5.3-invalid-MIT-cookie.patch")
+
+src_prepare() {
+ base_src_prepare
+ if ! use consolekit; then
+ sed -e 's@consolekit=yes@consolekit=no@' \
+ -i "${S}/src/cdmrc" || die "Could not turn off consolekit in cdmrc"
+ fi
+}
+
+src_install() {
+ if use pam ; then
+ pamd_mimic system-local-login cdm auth account session
+ fi
+
+ insinto /usr/bin/
+ insopts -m0755
+ dobin src/${PN}
+
+ insinto /etc
+ insopts -Dm644
+ doins src/cdmrc
+
+ insinto /usr/share/${PN}
+ insopts -m644
+ doins src/xinitrc*
+
+ insinto /etc/profile.d/
+ insopts -Dm755
+ doins src/zzz-${PN}-profile.sh
+
+ # Install themes
+ insinto /usr/share/${PN}/themes
+ doins src/themes/*
+ # Copy documentation manually
+ dodoc CHANGELOG
+}
+
+pkg_postinst() {
+ einfo "In order to use CDM you must first edit your /etc/cdmrc"
+ einfo "At least these should be edited before you start using CDM:"
+ einfo "wmbinlist=(awesome openbox-session startkde startxfce4 gnome-session)"
+ einfo "wmdisplist=(Awesome Openbox KDE Xfce Gnome)"
+ einfo "Add whatever WM/DE you have."
+ einfo "Then just login with your username"
+ ewarn "Remove xdm from default runlevel"
+}
diff --git a/x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild b/x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild
new file mode 100644
index 000000000000..5d0dcb7860e0
--- /dev/null
+++ b/x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit pam eutils
+
+DESCRIPTION="The Console Display Manager"
+HOMEPAGE="https://wiki.archlinux.org/index.php/CDM"
+SRC_URI="http://dev.gentoo.org/~gienah/snapshots/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam consolekit"
+REQUIRED_USE="consolekit? ( pam )"
+
+DEPEND="app-shells/bash"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog
+ x11-apps/xdpyinfo
+ x11-apps/xinit
+ consolekit? ( sys-auth/consolekit
+ sys-apps/dbus )
+ pam? ( virtual/pam )"
+
+src_prepare() {
+ if ! use consolekit; then
+ sed -e 's@consolekit=yes@consolekit=no@' \
+ -i "${S}/src/cdmrc" || die "Could not turn off consolekit in cdmrc"
+ fi
+}
+
+src_install() {
+ if use pam ; then
+ pamd_mimic system-local-login cdm auth account session
+ fi
+
+ insinto /usr/bin/
+ insopts -m0755
+ dobin src/${PN} src/${PN}-xlaunch
+
+ insinto /etc
+ insopts -Dm644
+ doins src/cdmrc
+
+ insinto /etc/profile.d/
+ insopts -Dm755
+ newins src/profile.sh zzz-${PN}.sh
+
+ # Install themes
+ insinto /usr/share/${PN}/themes
+ doins themes/*
+ # Copy documentation manually
+ dodoc ChangeLog-0.6 ChangeLog-before-0.6 README.md
+}
+
+pkg_postinst() {
+ ewarn "In order to use CDM you must first edit your /etc/cdmrc"
+ ewarn "At least the binlist, namelist and flaglist entries should be added or edited"
+ ewarn "to specify the X window managers and console shells that you want before"
+ ewarn "you start CDM. Something like:"
+ ewarn "binlist=('xmonad' 'startkde' '/bin/zsh --login' '/bin/bash --login')"
+ ewarn "namelist=('XMonad' 'KDE' 'Console Zsh' 'Console Bash')"
+ ewarn "flaglist=(X X C C)"
+ ewarn "Ensure the flaglist X entries correspond to the X-Windows programs, and the"
+ ewarn "C entries correspond to console shells. Then just login with your username."
+ ewarn "Remove xdm from default runlevel."
+}
diff --git a/x11-misc/cdm/files/cdm-0.5.3-invalid-MIT-cookie.patch b/x11-misc/cdm/files/cdm-0.5.3-invalid-MIT-cookie.patch
new file mode 100644
index 000000000000..1cec2b5c44a6
--- /dev/null
+++ b/x11-misc/cdm/files/cdm-0.5.3-invalid-MIT-cookie.patch
@@ -0,0 +1,19 @@
+commit c4b831f919e695d1c6882fbd76900dfa0f64cab5
+Author: ShadowKyogre <shadowkyogre@aim.com>
+Date: Sat Feb 11 17:44:23 2012 -0800
+
+ Add case for handling the Invalid MIT cookie or something.
+
+diff --git a/src/cdm b/src/cdm
+index d5aead5..59094cc 100755
+--- a/src/cdm
++++ b/src/cdm
+@@ -128,6 +128,8 @@ else
+ elif [[ $dpyinfo = No\ protocol\ specified* ]]; then
+ # Display is in use by another user
+ let display=display+1
++ elif [[ $dpyinfo = Invalid\ MIT* ]];then
++ let display=display+1
+ else
+ break
+ fi
diff --git a/x11-misc/cdm/metadata.xml b/x11-misc/cdm/metadata.xml
new file mode 100644
index 000000000000..1574d2cf1ad0
--- /dev/null
+++ b/x11-misc/cdm/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+</maintainer>
+<longdescription lang='en'>
+CDM is a minimalistic, yet full-featured replacement for
+login-managers like slim, kdm, gdm and qingy that provides a fast,
+dialog-based login system without the overhead of the X Window System
+or the instability of qingy. Written in pure bash, CDM has no other
+dependencies, yet supports multiple users/sessions and can start
+virtually any DE/WM.
+</longdescription>
+<use>
+ <flag name='consolekit'>Enable native consolekit support</flag>
+</use>
+</pkgmetadata>