summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2020-11-05 09:46:50 -0500
committerMarek Szuba <marecki@gentoo.org>2020-11-29 20:42:02 +0100
commitf69df3c1e7978b9bdca93b194a898d5baf239a2c (patch)
tree09a5cc234ca0b928ee21096c2635c19ada8ffb3b /x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
parentsci-astronomy/celestia: migrate to lua-single.eclass (diff)
downloadgentoo-f69df3c1e7978b9bdca93b194a898d5baf239a2c.tar.gz
gentoo-f69df3c1e7978b9bdca93b194a898d5baf239a2c.tar.bz2
gentoo-f69df3c1e7978b9bdca93b194a898d5baf239a2c.zip
x11-misc/devilspie2: port to lua-single eclass
With some cosmetic changes made and package.mask entry added by Marek Szuba at merge time. Closes: https://bugs.gentoo.org/752885 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-misc/devilspie2/devilspie2-0.43-r100.ebuild')
-rw-r--r--x11-misc/devilspie2/devilspie2-0.43-r100.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild b/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
new file mode 100644
index 000000000000..e9c87f823d33
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+PLOCALES="fi fr it ja nl pt_BR ru sv"
+
+inherit lua-single toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="https://www.nongnu.org/devilspie2/"
+SRC_URI="https://download.savannah.gnu.org/releases/devilspie2/devilspie2_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ >=dev-libs/glib-2.32.4:2
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.43-lua-pkgconfig.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${ED}" LANGUAGES="$(l10n_get_locales)" install
+ einstalldocs
+ doman devilspie2.1
+}