summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:19:37 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:11 +0100
commit4da4d7a26be568a11dbe84c62347f25ed54baf4e (patch)
tree84fa865f4f1684b3baedd03b3b9b9c87210fbde6 /x11-misc/devilspie2
parentx11-misc/chgres: respect PKG_CONFIG (diff)
downloadgentoo-4da4d7a26be568a11dbe84c62347f25ed54baf4e.tar.gz
gentoo-4da4d7a26be568a11dbe84c62347f25ed54baf4e.tar.bz2
gentoo-4da4d7a26be568a11dbe84c62347f25ed54baf4e.zip
x11-misc/devilspie2: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/devilspie2')
-rw-r--r--x11-misc/devilspie2/devilspie2-0.43-r100.ebuild1
-rw-r--r--x11-misc/devilspie2/files/devilspie2-0.43-lua-pkgconfig.patch4
2 files changed, 3 insertions, 2 deletions
diff --git a/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild b/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
index 6adedca29b23..ffca8f7fa9be 100644
--- a/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
+++ b/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
@@ -38,6 +38,7 @@ PATCHES=(
)
src_compile() {
+ tc-export PKG_CONFIG
emake CC="$(tc-getCC)" PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
}
diff --git a/x11-misc/devilspie2/files/devilspie2-0.43-lua-pkgconfig.patch b/x11-misc/devilspie2/files/devilspie2-0.43-lua-pkgconfig.patch
index 89c74d0bbb4e..4b832e6a7fcc 100644
--- a/x11-misc/devilspie2/files/devilspie2-0.43-lua-pkgconfig.patch
+++ b/x11-misc/devilspie2/files/devilspie2-0.43-lua-pkgconfig.patch
@@ -4,9 +4,9 @@
endif
-LIB_CFLAGS=$(shell pkg-config --cflags --silence-errors $(PKG_GTK) $(PKG_WNCK) lua5.1 || pkg-config --cflags $(PKG_GTK) $(PKG_WNCK) lua)
-+LIB_CFLAGS=$(shell pkg-config --cflags $(PKG_GTK) $(PKG_WNCK) lua)
++LIB_CFLAGS=$(shell ${PKG_CONFIG} --cflags $(PKG_GTK) $(PKG_WNCK) lua)
STD_LDFLAGS=
-LIBS=-lX11 $(shell pkg-config --libs --silence-errors $(PKG_GTK) $(PKG_WNCK) lua5.1 || pkg-config --libs $(PKG_GTK) $(PKG_WNCK) lua)
-+LIBS=-lX11 $(shell pkg-config --libs $(PKG_GTK) $(PKG_WNCK) lua)
++LIBS=-lX11 $(shell ${PKG_CONFIG} --libs $(PKG_GTK) $(PKG_WNCK) lua)
LOCAL_CFLAGS=$(STD_CFLAGS) $(DEPRECATED) $(CFLAGS) $(LIB_CFLAGS)