summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/dzen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/dzen')
-rw-r--r--x11-misc/dzen/Manifest1
-rw-r--r--x11-misc/dzen/dzen-0.9.5-r1.ebuild79
-rw-r--r--x11-misc/dzen/files/dzen-0.9.5-config-default.patch95
-rw-r--r--x11-misc/dzen/files/dzen-0.9.5-off-by-one.patch11
-rw-r--r--x11-misc/dzen/metadata.xml12
5 files changed, 198 insertions, 0 deletions
diff --git a/x11-misc/dzen/Manifest b/x11-misc/dzen/Manifest
new file mode 100644
index 000000000000..022309b40880
--- /dev/null
+++ b/x11-misc/dzen/Manifest
@@ -0,0 +1 @@
+DIST dzen-0.9.5.tar.gz 38167 SHA256 0556c815de7257bccd50cfa62371e4bc1c358fa1c5a179a4f99890a63912dc19 SHA512 ed4eb5d657d8f3822d8fbf224da5c2d415852c340959840051ec9cfc63f90361e09b9d36cb8221cf046ae66af02b9fab67f4f16c834c5895e801d452e4f8a916 WHIRLPOOL d26831f48effe502e26f5a84c1a3ff18498d8c83053c716e75f4e695af3eec99f5f7fb19132e2d2ac13350d949bc2d9484607ea5a1cbed4b9682f15144ec9d3d
diff --git a/x11-misc/dzen/dzen-0.9.5-r1.ebuild b/x11-misc/dzen/dzen-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..9deff6330500
--- /dev/null
+++ b/x11-misc/dzen/dzen-0.9.5-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs vcs-snapshot
+
+COMMITID="f7907da3a42a6d59e27ede88f5f01e4e41c4c9e0"
+
+DESCRIPTION="a general purpose messaging, notification and menuing program for X11"
+HOMEPAGE="https://github.com/robm/dzen"
+SRC_URI="https://github.com/robm/${PN}/tarball/${COMMITID} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+IUSE="minimal xft xinerama xpm"
+SLOT="2"
+
+RDEPEND="
+ x11-libs/libX11
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )
+"
+
+DOCS=( README )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-config-default.patch \
+ "${FILESDIR}"/${P}-off-by-one.patch
+
+ sed -i \
+ -e '/strip/d' \
+ -e 's:^ @: :g' \
+ -e 's:{CC}:(CC):g' \
+ Makefile gadgets/Makefile || die
+
+ tc-export CC PKG_CONFIG
+}
+
+src_configure() {
+ if use xinerama ; then
+ sed -e '/^LIBS/s|$| -lXinerama|' \
+ -e '/^CFLAGS/s|$| -DDZEN_XINERAMA|' \
+ -i config.mk || die
+ fi
+ if use xpm ; then
+ sed -e '/^LIBS/s|$| -lXpm|' \
+ -e '/^CFLAGS/s|$| -DDZEN_XPM|' \
+ -i config.mk || die
+ fi
+ if use xft ; then
+ sed -e '/^LIBS/s|$| $(shell ${PKG_CONFIG} --libs xft)|' \
+ -e '/^CFLAGS/s|$| -DDZEN_XFT $(shell ${PKG_CONFIG} --cflags xft)|' \
+ -i config.mk || die
+ fi
+}
+
+src_compile() {
+ default
+ use minimal || emake -C gadgets
+}
+
+src_install() {
+ default
+
+ if ! use minimal ; then
+ emake -C gadgets DESTDIR="${D}" install
+ dobin gadgets/*.sh
+ dodoc gadgets/README*
+ fi
+}
diff --git a/x11-misc/dzen/files/dzen-0.9.5-config-default.patch b/x11-misc/dzen/files/dzen-0.9.5-config-default.patch
new file mode 100644
index 000000000000..2fcdddbf6a68
--- /dev/null
+++ b/x11-misc/dzen/files/dzen-0.9.5-config-default.patch
@@ -0,0 +1,95 @@
+--- a/config.mk
++++ b/config.mk
+@@ -4,7 +4,7 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
++PREFIX = /usr
+ MANPREFIX = ${PREFIX}/share/man
+
+ X11INC = /usr/X11R6/include
+@@ -19,55 +19,12 @@
+ # Comment : Add # to the beginning of the respective lines
+
+ ## Option 1: No Xinerama no XPM no XFT
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\"
+-
+-
+-## Option 2: No Xinerama with XPM
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXpm
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XPM
+-
+-
+-# Option 3: With Xinerama no XPM
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXinerama
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XINERAMA
+-
+-
+-## Option 4: With Xinerama and XPM
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXinerama -lXpm
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XINERAMA -DDZEN_XPM
+-
+-
+-## Option 5: With XFT
+-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 `pkg-config --libs xft`
+-CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XFT `pkg-config --cflags xft`
+-
+-
+-## Option 6: With XPM and XFT
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXpm `pkg-config --libs xft`
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XPM -DDZEN_XFT `pkg-config --cflags xft`
+-
+-
+-## Option 7: With Xinerama and XPM and XFT
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXinerama -lXpm `pkg-config --libs xft`
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XINERAMA -DDZEN_XPM -DDZEN_XFT `pkg-config --cflags xft`
+-
+-
++LIBS = -lX11
++CFLAGS += -Wall ${INCS} -DVERSION=\"${VERSION}\"
+
+ # END of feature configuration
+
+-
+-LDFLAGS = ${LIBS}
+-
+-# Solaris, uncomment for Solaris
+-#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+-#LDFLAGS = ${LIBS}
+-#CFLAGS += -xtarget=ultra
+-
+-# Debugging
+-#CFLAGS = ${INCS} -DVERSION=\"${VERSION}\" -std=gnu89 -pedantic -Wall -W -Wundef -Wendif-labels -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wdisabled-optimization -O2 -pipe -DDZEN_XFT `pkg-config --cflags xft`
+-#LDFLAGS = ${LIBS}
++LDFLAGS += ${LIBS}
+
+ # compiler and linker
+-CC = gcc
+-LD = ${CC}
++LD = $(CC)
+--- a/gadgets/config.mk
++++ b/gadgets/config.mk
+@@ -1,7 +1,7 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
++PREFIX = /usr
+ MANPREFIX = ${PREFIX}/share/man
+
+ X11INC = /usr/X11R6/include
+@@ -10,9 +10,8 @@
+ X11LIB = /usr/X11R6/lib
+ LIBS = -L/usr/lib
+
+-CFLAGS = -Os ${INCS}
+-LDFLAGS = ${LIBS}
++CFLAGS += ${INCS}
++LDFLAGS += ${LIBS}
+
+ # compiler and linker
+-CC = gcc
+-LD = ${CC}
++LD = $(CC)
diff --git a/x11-misc/dzen/files/dzen-0.9.5-off-by-one.patch b/x11-misc/dzen/files/dzen-0.9.5-off-by-one.patch
new file mode 100644
index 000000000000..008fd6455014
--- /dev/null
+++ b/x11-misc/dzen/files/dzen-0.9.5-off-by-one.patch
@@ -0,0 +1,11 @@
+--- a/main.c
++++ b/main.c
+@@ -109,7 +109,7 @@
+ rem = NULL;
+ }
+ while(off < len) {
+- if(i > MAX_LINE_LEN) {
++ if(i == MAX_LINE_LEN - 1) {
+ outbuf[i] = '\0';
+ return ++off;
+ }
diff --git a/x11-misc/dzen/metadata.xml b/x11-misc/dzen/metadata.xml
new file mode 100644
index 000000000000..a5cf379b5fce
--- /dev/null
+++ b/x11-misc/dzen/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <longdescription>Dzen is a general purpose messaging, notification and menuing
+ program for X11. It was designed to be scriptable in any language and
+ integrate well with window managers like dwm, wmii and xmonad though it will
+ work with any window manager.</longdescription>
+ <upstream>
+ <remote-id type="github">robm/dzen</remote-id>
+ </upstream>
+</pkgmetadata>