summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-01 15:03:43 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-01 15:03:57 +0100
commit9cd2c526d77f0e7a7ab5bb10111b82095f0d0883 (patch)
tree87e5799af8fdf7ecb710008078ee74d8b6850846 /x11-misc/fbpanel
parentx11-misc/efax-gtk: Drop IUSE=nls (diff)
downloadgentoo-9cd2c526d77f0e7a7ab5bb10111b82095f0d0883.tar.gz
gentoo-9cd2c526d77f0e7a7ab5bb10111b82095f0d0883.tar.bz2
gentoo-9cd2c526d77f0e7a7ab5bb10111b82095f0d0883.zip
x11-misc/fbpanel: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/fbpanel')
-rw-r--r--x11-misc/fbpanel/fbpanel-7.0-r1.ebuild3
-rw-r--r--x11-misc/fbpanel/files/fbpanel-7.0-fno-common.patch21
2 files changed, 23 insertions, 1 deletions
diff --git a/x11-misc/fbpanel/fbpanel-7.0-r1.ebuild b/x11-misc/fbpanel/fbpanel-7.0-r1.ebuild
index 9acb74d5c5ff..b468b2a537e8 100644
--- a/x11-misc/fbpanel/fbpanel-7.0-r1.ebuild
+++ b/x11-misc/fbpanel/fbpanel-7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,6 +34,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.0-clang.patch
"${FILESDIR}"/${PN}-7.0-images.patch
"${FILESDIR}"/${PN}-7.0-shebangs.patch
+ "${FILESDIR}"/${PN}-7.0-fno-common.patch
)
src_configure() {
diff --git a/x11-misc/fbpanel/files/fbpanel-7.0-fno-common.patch b/x11-misc/fbpanel/files/fbpanel-7.0-fno-common.patch
new file mode 100644
index 000000000000..aafd8c4cc67b
--- /dev/null
+++ b/x11-misc/fbpanel/files/fbpanel-7.0-fno-common.patch
@@ -0,0 +1,21 @@
+--- a/panel/plugin.c
++++ b/panel/plugin.c
+@@ -22,6 +22,7 @@
+ /**************************************************************/
+ static GHashTable *class_ht;
+
++struct _plugin_instance *stam;
+
+ void
+ class_register(plugin_class *p)
+--- a/panel/plugin.h
++++ b/panel/plugin.h
+@@ -9,7 +9,7 @@
+ #include <stdio.h>
+ #include "panel.h"
+
+-struct _plugin_instance *stam;
++extern struct _plugin_instance *stam;
+
+ typedef struct {
+ /* common */