summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 23:21:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 23:22:28 +0200
commitd4cd7d9dc3e0951944f93f5ae32348bebfac7718 (patch)
treebb97bfa7bf02a2e9c905281902a12552787f7901 /x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
parentapp-emacs/prom-wl: Remove last-rited pkg (diff)
downloadgentoo-d4cd7d9dc3e0951944f93f5ae32348bebfac7718.tar.gz
gentoo-d4cd7d9dc3e0951944f93f5ae32348bebfac7718.tar.bz2
gentoo-d4cd7d9dc3e0951944f93f5ae32348bebfac7718.zip
x11-misc/flow-pomodoro: Fix popups with Qt 5.12, EAPI-7 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild')
-rw-r--r--x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..4285248dec78
--- /dev/null
+++ b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A pomodoro app that blocks distractions while you work"
+HOMEPAGE="https://github.com/iamsergio/flow-pomodoro"
+SRC_URI="https://github.com/iamsergio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.12.patch" )