summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/gbase/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/gbase/files')
-rw-r--r--x11-misc/gbase/files/gbase-0.5-gtk.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/gbase/files/gbase-0.5-gtk.patch b/x11-misc/gbase/files/gbase-0.5-gtk.patch
new file mode 100644
index 000000000000..38936e79738c
--- /dev/null
+++ b/x11-misc/gbase/files/gbase-0.5-gtk.patch
@@ -0,0 +1,26 @@
+diff -ur gbase-0.5.orig/Makefile gbase-0.5/Makefile
+--- gbase-0.5.orig/Makefile 1999-10-28 00:23:51.000000000 +0300
++++ gbase-0.5/Makefile 2008-01-16 14:24:55.000000000 +0200
+@@ -1,15 +1,15 @@
+-CC = gcc
+-CCFLAGS = `gtk-config --cflags`
+-LDFLAGS = `gtk-config --libs`
++CC ?= gcc
++CFLAGS += `pkg-config --cflags gtk+-2.0`
++LIBS = `pkg-config --libs gtk+-2.0`
+
+ gbase: gbase.o
+- $(CC) gbase.o $(LDFLAGS) -o gbase
++ $(CC) $(LDFLAGS) gbase.o $(LIBS) -o gbase
+
+ clean:
+ rm -f gbase gbase.o gbase.c~
+
+ # Make object files:
+ %.o:
+- $(CC) $(CCFLAGS) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+-gbase.o: gbase.c
+\ No newline at end of file
++gbase.o: gbase.c