summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-15 05:43:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-15 18:01:03 +0100
commit170775d67ae2a6cac693a7bed613339df3ee8e1e (patch)
treedfec2006e1ca022e0b28ec6bc3bb86d914524b52 /x11-misc/gigolo/gigolo-0.5.1.ebuild
parentdev-python/PyGithub: Bump to 1.47 (diff)
downloadgentoo-170775d67ae2a6cac693a7bed613339df3ee8e1e.tar.gz
gentoo-170775d67ae2a6cac693a7bed613339df3ee8e1e.tar.bz2
gentoo-170775d67ae2a6cac693a7bed613339df3ee8e1e.zip
x11-misc/gigolo: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-misc/gigolo/gigolo-0.5.1.ebuild')
-rw-r--r--x11-misc/gigolo/gigolo-0.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/gigolo/gigolo-0.5.1.ebuild b/x11-misc/gigolo/gigolo-0.5.1.ebuild
new file mode 100644
index 000000000000..227fa91f3625
--- /dev/null
+++ b/x11-misc/gigolo/gigolo-0.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="a frontend to easily manage connections to remote filesystems using GIO/GVfs"
+HOMEPAGE="https://www.uvena.de/gigolo/ https://goodies.xfce.org/projects/applications/gigolo"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-3.14:3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm COPYING || die
+ default
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}