summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-07 18:26:40 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-07 18:26:40 +0100
commitdfae0b2159c668c8c178c7dec27dc867a2c8bb4a (patch)
treeb101c7ac97e60e9392b659f65e4d5b2efe213d4e /x11-misc/gmrun
parentdev-java/mill-bin: add 0.10.10 (diff)
downloadgentoo-dfae0b2159c668c8c178c7dec27dc867a2c8bb4a.tar.gz
gentoo-dfae0b2159c668c8c178c7dec27dc867a2c8bb4a.tar.bz2
gentoo-dfae0b2159c668c8c178c7dec27dc867a2c8bb4a.zip
x11-misc/gmrun: drop 0.9.2-r2
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/gmrun')
-rw-r--r--x11-misc/gmrun/Manifest1
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch40
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-gcc6-pie.patch84
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch11
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch35
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch41
-rw-r--r--x11-misc/gmrun/gmrun-0.9.2-r2.ebuild36
7 files changed, 0 insertions, 248 deletions
diff --git a/x11-misc/gmrun/Manifest b/x11-misc/gmrun/Manifest
index 8087db6e09bf..9c3720eb890c 100644
--- a/x11-misc/gmrun/Manifest
+++ b/x11-misc/gmrun/Manifest
@@ -1,2 +1 @@
-DIST gmrun-0.9.2.tar.gz 66097 BLAKE2B 3b8f253e8d683d02c8b6cc8da3d54103b53c6b9ebd4d90b4675325809f592f407a32532e6f0d3d3a112f5c7b9304eaae75bc3ba7f1e1b372614d95206edf0da3 SHA512 3ce881463c23b6c2c39b4d41ff98f3d4a2b77f45a46d4ac43d8bbf726fcb3769b643436932714f9f5c22b855188928453810468d165af2c2433059a0149d6422
DIST gmrun-1.4w.tar.xz 43304 BLAKE2B 14c4ffc0770b37d851ad101c7967f691801bf2e95abb8c7fc06abc7c39f94ffac289253febb51bdba6e5237abdea38981e8072ceb997fb410620f691b8fc7ae7 SHA512 3e36304782d4d288abf2e81b4dee60230d262fa9e3ca8ab236d52619f0a226cfa95c8cc830e6506308ed65191ff7295501a9dfe162b54d67ce1f9154d33d9473
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch b/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch
deleted file mode 100644
index e1d4d6d211ac..000000000000
--- a/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/src/gtkcompletionline.cc
-+++ b/src/gtkcompletionline.cc
-@@ -29,6 +29,7 @@
- #include <set>
- #include <sstream>
- #include <string>
-+#include <cstring>
- #include <vector>
- using namespace std;
-
---- a/src/ci_string.h
-+++ b/src/ci_string.h
-@@ -7,6 +7,7 @@
- #define __CI_STRING_H__
-
- #include <string>
-+#include <cstring>
- #include <ctype.h>
-
- struct ci_char_traits : public std::char_traits<char>
---- a/src/prefs.cc
-+++ b/src/prefs.cc
-@@ -13,6 +13,7 @@
- #include <fstream>
- #include <iostream>
- #include <stdio.h>
-+#include <stdlib.h>
-
- #include <list>
-
---- a/src/main.cc
-+++ b/src/main.cc
-@@ -14,6 +14,7 @@
- #include <gdk/gdkkeysyms.h>
-
- #include <string>
-+#include <cstring>
- #include <iostream>
- #include <sstream>
- #include <vector>
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-gcc6-pie.patch b/x11-misc/gmrun/files/gmrun-0.9.2-gcc6-pie.patch
deleted file mode 100644
index 3ef46c7bd653..000000000000
--- a/x11-misc/gmrun/files/gmrun-0.9.2-gcc6-pie.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 351d355835532dbea8430902977873e887dd1c12 Mon Sep 17 00:00:00 2001
-From: Lucian Poston <lucian.poston@gmail.com>
-Date: Wed, 6 Dec 2017 04:22:28 -0800
-Subject: [PATCH] fix segfault in gcc-6
-
----
- src/gtkcompletionline.cc | 27 +++++++++++++++------------
- src/gtkcompletionline.h | 2 +-
- 2 files changed, 16 insertions(+), 13 deletions(-)
-
-diff --git a/src/gtkcompletionline.cc b/src/gtkcompletionline.cc
-index eb324b5..537fafb 100644
---- a/src/gtkcompletionline.cc
-+++ b/src/gtkcompletionline.cc
-@@ -77,22 +77,25 @@ static gboolean
- on_key_press(GtkCompletionLine *cl, GdkEventKey *event, gpointer data);
-
- /* get_type */
--guint gtk_completion_line_get_type(void)
-+GType gtk_completion_line_get_type(void)
- {
-- static guint type = 0;
-+ static GType type = 0;
- if (type == 0)
- {
-- GtkTypeInfo type_info =
-+ static const GTypeInfo type_info =
- {
-- "GtkCompletionLine",
-- sizeof(GtkCompletionLine),
- sizeof(GtkCompletionLineClass),
-- (GtkClassInitFunc)gtk_completion_line_class_init,
-- (GtkObjectInitFunc)gtk_completion_line_init,
-- /*(GtkArgSetFunc)*/NULL /* reserved */,
-- /*(GtkArgGetFunc)*/NULL /* reserved */
-+ NULL,
-+ NULL,
-+ (GClassInitFunc)gtk_completion_line_class_init,
-+ NULL,
-+ NULL,
-+ sizeof(GtkCompletionLine),
-+ 0,
-+ (GInstanceInitFunc)gtk_completion_line_init,
-+ NULL
- };
-- type = gtk_type_unique(gtk_entry_get_type(), &type_info);
-+ type = g_type_register_static(GTK_TYPE_ENTRY, "GtkCompletionLine", &type_info, (GTypeFlags)0);
- }
- return type;
- }
-@@ -114,7 +117,7 @@ gtk_completion_line_class_init(GtkCompletionLineClass *klass)
-
- gtk_completion_line_signals[NOTUNIQUE] =
- gtk_signal_new("notunique",
-- GTK_RUN_FIRST, G_TYPE_FROM_CLASS(object_class),
-+ GTK_RUN_FIRST, G_TYPE_FROM_CLASS(object_class),
- GTK_SIGNAL_OFFSET(GtkCompletionLineClass,
- notunique),
- gtk_signal_default_marshaller, GTK_TYPE_NONE, 0);
-@@ -778,7 +781,7 @@ complete_line(GtkCompletionLine *object)
- GtkWidget *
- gtk_completion_line_new()
- {
-- return GTK_WIDGET(gtk_type_new(gtk_completion_line_get_type()));
-+ return GTK_WIDGET(g_object_new(gtk_completion_line_get_type(), NULL));
- }
-
- static void
-diff --git a/src/gtkcompletionline.h b/src/gtkcompletionline.h
-index 5e14cd7..0d7f2dc 100644
---- a/src/gtkcompletionline.h
-+++ b/src/gtkcompletionline.h
-@@ -76,7 +76,7 @@ extern "C++" {
- void (* cancel)(GtkCompletionLine *cl);
- };
-
-- guint gtk_completion_line_get_type(void);
-+ GType gtk_completion_line_get_type(void);
- GtkWidget *gtk_completion_line_new();
-
- void gtk_completion_line_last_history_item(GtkCompletionLine*);
---
-2.13.6
-
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch b/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch
deleted file mode 100644
index 6e12a56f431d..000000000000
--- a/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/gtkcompletionline.cc
-+++ b/src/gtkcompletionline.cc
-@@ -376,7 +377,7 @@
- return 0;
- }
-
--int my_alphasort(const void* va, const void* vb) {
-+int my_alphasort(const dirent** va, const dirent** vb) {
- const struct dirent** a = (const struct dirent**)va;
- const struct dirent** b = (const struct dirent**)vb;
-
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch b/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch
deleted file mode 100644
index 426f652a0c2b..000000000000
--- a/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=164339
-
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -1,7 +1,7 @@
- ## Process this file with automake to produce Makefile.in
-
- INCLUDES = \
-- @GTK_CFLAGS@ @STLPORT_CXXFLAGS@
-+ @GTK_CFLAGS@
-
- bin_PROGRAMS = gmrun
-
-@@ -13,7 +13,7 @@
-
- # gmrun_LDFLAGS = -s
-
--gmrun_LDADD = @GTK_LIBS@ @STLPORT_LDFLAGS@
-+gmrun_LDADD = @GTK_LIBS@
-
- AM_CPPFLAGS = \
- -DPACKAGE_DATA_DIR='"$(datadir)/$(PACKAGE)"' -DPACKAGE_SYSCONF_DIR='"$(sysconfdir)"'
---- a/configure.in
-+++ b/configure.in
-@@ -37,8 +37,8 @@
- AC_HEADER_DIRENT
- AC_HEADER_STDC
- AC_PROG_CXX
--AC_PATH_STLPORT_LIB
--AC_PATH_STLPORT_INC
-+dnl REMOVED _LIB
-+dnl REMOVED _INC
-
-
- AC_CHECK_FUNC( poptGetContext,
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
deleted file mode 100644
index 92db743a8df5..000000000000
--- a/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-http://bugs.gentoo.org/292856
-
---- a/config/Makefile.am
-+++ b/config/Makefile.am
-@@ -1,6 +1,6 @@
- # $Id$
-
--myrcdir = @PACKAGE_DATA_DIR@
-+myrcdir = $(sysconfdir)
- myrc_DATA = gmrunrc
-
- EXTRA_DIST = gmrunrc
---- a/config.h.in
-+++ b/config.h.in
-@@ -10,7 +10,6 @@
- #undef HAVE_STPCPY
- #undef HAVE_LIBSM
- #undef PACKAGE_LOCALE_DIR
--#undef PACKAGE_DATA_DIR
- #undef PACKAGE_SOURCE_DIR
-
- /* Define if you have the <dirent.h> header file. */
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -15,3 +15,5 @@
-
- gmrun_LDADD = @GTK_LIBS@ @STLPORT_LDFLAGS@
-
-+AM_CPPFLAGS = \
-+ -DPACKAGE_DATA_DIR='"$(datadir)/$(PACKAGE)"' -DPACKAGE_SYSCONF_DIR='"$(sysconfdir)"'
---- a/src/prefs.cc
-+++ b/src/prefs.cc
-@@ -30,7 +30,7 @@
-
- Prefs::Prefs()
- {
-- string file_name = PACKAGE_DATA_DIR"/";
-+ string file_name = PACKAGE_SYSCONF_DIR"/";
- file_name += GMRUNRC;
- init(file_name);
-
diff --git a/x11-misc/gmrun/gmrun-0.9.2-r2.ebuild b/x11-misc/gmrun/gmrun-0.9.2-r2.ebuild
deleted file mode 100644
index ba116f437ace..000000000000
--- a/x11-misc/gmrun/gmrun-0.9.2-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools
-
-DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
-HOMEPAGE="https://sourceforge.net/projects/gmrun/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-1"
-SLOT="0"
-KEYWORDS="amd64 ~mips ppc x86"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/popt
- x11-libs/gtk+:2
-"
-DEPEND="
- ${RDEPEND}
- elibc_glibc? ( >=sys-libs/glibc-2.10 )
- virtual/pkgconfig
-"
-
-src_prepare() {
- eapply \
- "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-gcc6-pie.patch \
- "${FILESDIR}"/${P}-sysconfdir.patch \
- "${FILESDIR}"/${P}-glibc210.patch \
- "${FILESDIR}"/${P}-stlport.patch
-
- eapply_user
- eautoreconf
-}