summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-12-04 04:33:50 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-12-04 04:50:37 -0500
commit378ae86f360a85b15e7d071d7298187c4a45cabc (patch)
tree03001f62f39e3ffdc1a9856f1ee0b41f0c91980a /x11-misc/growl-for-linux
parentdev-libs/nspr: Bump to version 4.11 (diff)
downloadgentoo-378ae86f360a85b15e7d071d7298187c4a45cabc.tar.gz
gentoo-378ae86f360a85b15e7d071d7298187c4a45cabc.tar.bz2
gentoo-378ae86f360a85b15e7d071d7298187c4a45cabc.zip
x11-misc/growl-for-linux: add libressl support
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-misc/growl-for-linux')
-rw-r--r--x11-misc/growl-for-linux/growl-for-linux-0.6.7-r1.ebuild42
-rw-r--r--x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild4
-rw-r--r--x11-misc/growl-for-linux/growl-for-linux-9999.ebuild6
3 files changed, 48 insertions, 4 deletions
diff --git a/x11-misc/growl-for-linux/growl-for-linux-0.6.7-r1.ebuild b/x11-misc/growl-for-linux/growl-for-linux-0.6.7-r1.ebuild
new file mode 100644
index 000000000000..69103e2a6772
--- /dev/null
+++ b/x11-misc/growl-for-linux/growl-for-linux-0.6.7-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="Growl Implementation For Linux"
+HOMEPAGE="https://mattn.github.com/growl-for-linux/"
+SRC_URI="mirror://github/mattn/growl-for-linux/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ dev-libs/libxml2
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ net-misc/curl
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ local myeconfargs=(
+ LIBS=-lgthread-2.0
+ --disable-static
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --modules
+}
diff --git a/x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild b/x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild
index c406ebeeff83..10f7e1ed8c66 100644
--- a/x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild
+++ b/x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,7 +18,7 @@ RDEPEND="dev-db/sqlite:3
dev-libs/dbus-glib
dev-libs/glib:2
dev-libs/libxml2
- dev-libs/openssl
+ dev-libs/openssl:0
net-misc/curl
x11-libs/gtk+:2"
DEPEND="${RDEPEND}
diff --git a/x11-misc/growl-for-linux/growl-for-linux-9999.ebuild b/x11-misc/growl-for-linux/growl-for-linux-9999.ebuild
index 5787e8dcfe09..4d7816906044 100644
--- a/x11-misc/growl-for-linux/growl-for-linux-9999.ebuild
+++ b/x11-misc/growl-for-linux/growl-for-linux-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,12 +14,14 @@ HOMEPAGE="https://mattn.github.com/growl-for-linux/"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS=""
+IUSE="libressl"
RDEPEND="dev-db/sqlite:3
dev-libs/dbus-glib
dev-libs/glib:2
dev-libs/libxml2
- dev-libs/openssl
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
net-misc/curl
x11-libs/gtk+:2"
DEPEND="${RDEPEND}