summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-01-20 09:13:31 -0600
committerBen Kohler <bkohler@gentoo.org>2021-01-20 09:16:51 -0600
commit809b9ef0d67325352763fab5f12576f5949622eb (patch)
tree81e4b3ebd42fbcbdf68df580ee9d9d575884cb9a /x11-misc/i3blocks/i3blocks-1.5-r1.ebuild
parentx11-misc/i3blocks-contrib: new package (diff)
downloadgentoo-809b9ef0d67325352763fab5f12576f5949622eb.tar.gz
gentoo-809b9ef0d67325352763fab5f12576f5949622eb.tar.bz2
gentoo-809b9ef0d67325352763fab5f12576f5949622eb.zip
x11-misc/i3blocks: depend on contrib modules by default
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'x11-misc/i3blocks/i3blocks-1.5-r1.ebuild')
-rw-r--r--x11-misc/i3blocks/i3blocks-1.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/i3blocks/i3blocks-1.5-r1.ebuild b/x11-misc/i3blocks/i3blocks-1.5-r1.ebuild
new file mode 100644
index 000000000000..418265489eaa
--- /dev/null
+++ b/x11-misc/i3blocks/i3blocks-1.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="highly flexible status line for the i3 window manager"
+HOMEPAGE="https://github.com/vivien/i3blocks"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/vivien/${PN}"
+else
+ SRC_URI="https://github.com/vivien/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+IUSE="+contrib"
+SLOT="0"
+LICENSE="GPL-3"
+
+PDEPEND="contrib? ( x11-misc/i3blocks-contrib )"
+
+PATCHES=( "${FILESDIR}"/${PN}-disable-bash-completion.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ newbashcomp bash-completion ${PN}
+}