summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-27 18:36:59 -0500
committerMatt Turner <mattst88@gentoo.org>2018-07-27 17:38:26 -0700
commit74852defe8df725486788a0861aad5dc45ba835d (patch)
tree8bfa310aac539942ff2a924db2d45a57ae83f6a1 /x11-misc/imake
parentx11-misc/xorg-cf-files: port to EAPI 7 (diff)
downloadgentoo-74852defe8df725486788a0861aad5dc45ba835d.tar.gz
gentoo-74852defe8df725486788a0861aad5dc45ba835d.tar.bz2
gentoo-74852defe8df725486788a0861aad5dc45ba835d.zip
x11-misc/imake: port to EAPI 7
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'x11-misc/imake')
-rw-r--r--x11-misc/imake/files/imake-1.0.7-sun-compiler.patch19
-rw-r--r--x11-misc/imake/imake-1.0.7-r1.ebuild50
2 files changed, 69 insertions, 0 deletions
diff --git a/x11-misc/imake/files/imake-1.0.7-sun-compiler.patch b/x11-misc/imake/files/imake-1.0.7-sun-compiler.patch
new file mode 100644
index 000000000000..27fe234f99ac
--- /dev/null
+++ b/x11-misc/imake/files/imake-1.0.7-sun-compiler.patch
@@ -0,0 +1,19 @@
+--- a/imake.c
++++ b/imake.c
+@@ -1,4 +1,6 @@
+-
++#if defined(sun)
++#undef sun
++#endif
+ /***************************************************************************
+ * *
+ * Porting Note *
+--- a/imakemdep.h
++++ b/imakemdep.h
+@@ -1,3 +1,6 @@
++#if defined(sun)
++#undef sun
++#endif
+ /*
+
+ Copyright (c) 1993, 1994, 1998 The Open Group
diff --git a/x11-misc/imake/imake-1.0.7-r1.ebuild b/x11-misc/imake/imake-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..a4ee1f9952ca
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.7-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C preprocessor interface to the make utility"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/util/imake.git"
+ inherit autotools git-r3
+ # x11-misc-util/macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/util/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ x11-misc/xorg-cf-files
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ "${FILESDIR}"/${PN}-1.0.7-sun-compiler.patch
+)
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+
+ econf "${econfargs[@]}"
+}