summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-03-02 19:04:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-02 21:10:32 +0100
commitd37da7c98c34f197eaa73ec6013631c9b244ad31 (patch)
treef9110efa126fde2ac181bbe59acc8bd908d86935 /x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild
parentsci-libs/dlib: version bump 19.16 fixing Python install (diff)
downloadgentoo-d37da7c98c34f197eaa73ec6013631c9b244ad31.tar.gz
gentoo-d37da7c98c34f197eaa73ec6013631c9b244ad31.tar.bz2
gentoo-d37da7c98c34f197eaa73ec6013631c9b244ad31.zip
x11-misc/j4-dmenu-desktop: bump to version 2.17
Also bumped to EAPI=7 and added myself as additional maintainer. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/11219 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild')
-rw-r--r--x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild b/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild
new file mode 100644
index 000000000000..8017519a1386
--- /dev/null
+++ b/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+MY_PV="r${PV}"
+
+DESCRIPTION="A fast desktop replacement for i3-dmenu-desktop"
+HOMEPAGE="https://github.com/enkore/${PN}"
+SRC_URI="https://github.com/enkore/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/catch:1 )"
+RDEPEND="x11-misc/dmenu"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Respect users CFLAGS
+ sed -i -e "s/-pedantic -O2//" CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_GIT_CATCH="no"
+ -DWITH_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ doman j4-dmenu-desktop.1
+}