summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-13 12:04:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-13 12:33:38 +0200
commit25eef3094abb676e947263762f5aa5b58f7148e9 (patch)
treee9311c0590a508a694ec0e54c9145d26459dddfe /x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-2.0.6.ebuild
parentgnome-base/nautilus: prepare for gvfs-1.34 (diff)
downloadgentoo-25eef3094abb676e947263762f5aa5b58f7148e9.tar.gz
gentoo-25eef3094abb676e947263762f5aa5b58f7148e9.tar.bz2
gentoo-25eef3094abb676e947263762f5aa5b58f7148e9.zip
x11-misc/lightdm-gtk-greeter: Bump to version 2.0.6
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-2.0.6.ebuild')
-rw-r--r--x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-2.0.6.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-2.0.6.ebuild b/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-2.0.6.ebuild
new file mode 100644
index 000000000000..b842a5130ef2
--- /dev/null
+++ b/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-2.0.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils eapi7-ver
+
+DESCRIPTION="LightDM GTK+ Greeter"
+HOMEPAGE="https://launchpad.net/lightdm-gtk-greeter"
+SRC_URI="https://launchpad.net/lightdm-gtk-greeter/$(ver_cut 1-2)/${PV}/+download/${P}.tar.gz
+ branding? ( https://dev.gentoo.org/~hwoarang/distfiles/lightdm-gentoo-patch-2.tar.gz )"
+
+LICENSE="GPL-3 LGPL-3
+ branding? ( CC-BY-3.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="ayatana branding"
+
+COMMON_DEPEND="ayatana? ( dev-libs/libindicator:3 )
+ x11-libs/gtk+:3
+ >=x11-misc/lightdm-1.2.2"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ xfce-base/exo"
+
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-themes-standard
+ >=x11-themes/adwaita-icon-theme-3.14.1"
+
+GENTOO_BG="gentoo-bg_65.jpg"
+
+src_prepare() {
+ # Ok, this has to be fixed in the tarball but I am too lazy to do it.
+ # I will fix this once I decide to update the tarball with a new gentoo
+ # background
+ # Bug #404467
+ if use branding; then
+ sed \
+ -e "/xft-hintstyle/s:slight:hintslight:" \
+ -e "/background/s:=.*:=/usr/share/lightdm/backgrounds/${GENTOO_BG}:" \
+ -i "${WORKDIR}"/${PN}.conf || die
+ # Add back the reboot/shutdown buttons
+ echo 'indicators=~host;~spacer;~clock;~spacer;~session;~language;~a11y;~power;~' \
+ >> "${WORKDIR}"/${PN}.conf || die
+ fi
+ default
+
+ # Fix docdir
+ sed "/^docdir/s@${PN}@${PF}@" -i data/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-kill-on-sigterm
+ --enable-at-spi-command="${EPREFIX}/usr/libexec/at-spi-bus-launcher --launch-immediately"
+ $(use_enable ayatana libindicator)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use branding; then
+ insinto /etc/lightdm/
+ doins "${WORKDIR}"/${PN}.conf
+ insinto /usr/share/lightdm/backgrounds/
+ doins "${WORKDIR}"/${GENTOO_BG}
+ newdoc "${WORKDIR}"/README.txt README-background.txt
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}