summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/lineakd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/lineakd')
-rw-r--r--x11-misc/lineakd/Manifest1
-rw-r--r--x11-misc/lineakd/files/lineakd-0.9.0-DELL-XPS-M1330-XOrg-1_5.patch32
-rw-r--r--x11-misc/lineakd/files/lineakd-0.9.0-gcc43.patch42
-rw-r--r--x11-misc/lineakd/lineakd-0.9.0-r1.ebuild61
-rw-r--r--x11-misc/lineakd/metadata.xml8
5 files changed, 144 insertions, 0 deletions
diff --git a/x11-misc/lineakd/Manifest b/x11-misc/lineakd/Manifest
new file mode 100644
index 000000000000..a89839fe3a81
--- /dev/null
+++ b/x11-misc/lineakd/Manifest
@@ -0,0 +1 @@
+DIST lineakd-0.9.tar.gz 991376 SHA256 39fd34f8df4d31d16adacce1191b34cef5e510b536701120906ec708be21010b SHA512 e30a2e111832e3f08bbff858647536aaeb75d20008618b8c7555836104fd5a66d8e3173d0f9da76906caf13e9c9753c9140cd22dbb96fde464ed5d5f254d721e WHIRLPOOL 6c6f556c34df24c1fe1c973cd813b7dd3f4b6c91836b49c84b7f1f8d6f1cc9463885396b505feda285e61e34623d443eeea70cfee68b18af8e3ca132b7bcd33f
diff --git a/x11-misc/lineakd/files/lineakd-0.9.0-DELL-XPS-M1330-XOrg-1_5.patch b/x11-misc/lineakd/files/lineakd-0.9.0-DELL-XPS-M1330-XOrg-1_5.patch
new file mode 100644
index 000000000000..4435b1a25e07
--- /dev/null
+++ b/x11-misc/lineakd/files/lineakd-0.9.0-DELL-XPS-M1330-XOrg-1_5.patch
@@ -0,0 +1,32 @@
+--- a/lineakd/lineakkb.def
++++ b/lineakd/lineakkb.def
+@@ -2040,9 +2040,29 @@
+ Previous = 144
+ Next = 153
+ Stop = 164
++ WinKey = 115
++ FnWinKey = 116
++ Menu = 117
+ [END KEYS]
+ [END DELL-XPS-GEN-2]
+
++[DELL-XPS-M1330-XOrg-1_5] # By skypjack
++ brandname = "Dell"
++ modelname = "Inspiron XPS M1330 XOrg 1.5"
++ [KEYS]
++ Mute = 121
++ VolumeDown = 122
++ VolumeUp = 123
++ Play|Pause = 172
++ Previous = 173
++ Next = 171
++ Stop = 174
++ WinKey = 133
++ FnWinKey = 134
++ Menu = 135
++ [END KEYS]
++[END DELL-XPS-M1330-XOrg-1_5]
++
+ [DELL-SK-8100] # By Akshoslaa
+ brandname = "Dell"
+ modelname = "SK-8100"
diff --git a/x11-misc/lineakd/files/lineakd-0.9.0-gcc43.patch b/x11-misc/lineakd/files/lineakd-0.9.0-gcc43.patch
new file mode 100644
index 000000000000..c36a7375c060
--- /dev/null
+++ b/x11-misc/lineakd/files/lineakd-0.9.0-gcc43.patch
@@ -0,0 +1,42 @@
+--- a/lineak/xmgr.cpp
++++ b/lineak/xmgr.cpp
+@@ -21,6 +21,8 @@
+ #include <lineak/lbutton.h>
+
+ extern "C" {
++ #include <stdlib.h>
++ #include <string.h>
+ #include <signal.h>
+ #include <X11/Xlib.h>
+ #include <X11/keysym.h>
+--- a/lineak/defloader.h
++++ b/lineak/defloader.h
+@@ -23,6 +23,7 @@
+ # endif
+
+ # include <lineak/loader.h>
++# include <cstdlib>
+ # include <map>
+
+ class LDef;
+--- a/lineak/pluginmanager.cpp
++++ b/lineak/pluginmanager.cpp
+@@ -34,6 +34,7 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <dlfcn.h>
++#include <string.h>
+ }
+
+ using namespace lineak_core_functions;
+--- a/lineak/cdromctrl.cpp
++++ b/lineak/cdromctrl.cpp
+@@ -51,6 +51,7 @@
+
+ #include <stdio.h>
+ #include <errno.h>
++#include <string.h>
+ #include <unistd.h>
+
+ }
+
diff --git a/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild b/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..b3cb416855c4
--- /dev/null
+++ b/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib
+
+MY_P=${P/.0/}
+
+DESCRIPTION="Linux support for Easy Access and Internet Keyboards features X11 support"
+HOMEPAGE="http://lineak.sourceforge.net"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-libs/libxkbfile
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXtst"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-DELL-XPS-M1330-XOrg-1_5.patch
+}
+
+src_configure() {
+ econf $(use_enable debug) --with-x
+}
+
+src_install() {
+ sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' lineakd/Makefile
+
+ dodir /usr/share/man/man8
+
+ emake -j1 DESTDIR="${D}" install
+ dodoc AUTHORS README TODO
+ keepdir /usr/$(get_libdir)/lineakd/plugins
+
+ insinto /etc/lineak
+ doins lineakd.conf.example lineakd.conf.kde.example
+}
+
+pkg_postinst() {
+ elog
+ elog "evtest utility has not been installed. evtest can be found"
+ elog "in games-util/joystick."
+ elog
+}
diff --git a/x11-misc/lineakd/metadata.xml b/x11-misc/lineakd/metadata.xml
new file mode 100644
index 000000000000..381a9fd5d696
--- /dev/null
+++ b/x11-misc/lineakd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">lineak</remote-id>
+ </upstream>
+</pkgmetadata>