summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-02 14:55:07 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-02 14:56:19 +0100
commit7114145023849eefe01d1d10961db27db900e020 (patch)
treedbf2a66b70f620e9b462ced5bd10ed1c558c1073 /x11-misc/lineakd
parentx11-misc/gxmessage: Version 2.20.4 (diff)
downloadgentoo-7114145023849eefe01d1d10961db27db900e020.tar.gz
gentoo-7114145023849eefe01d1d10961db27db900e020.tar.bz2
gentoo-7114145023849eefe01d1d10961db27db900e020.zip
x11-misc/lineakd: Uncompress man pages after default install
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/lineakd')
-rw-r--r--x11-misc/lineakd/lineakd-0.9.0-r3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild b/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild
new file mode 100644
index 000000000000..4848da2c45c0
--- /dev/null
+++ b/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib
+
+MY_P=${P/.0/}
+
+DESCRIPTION="Linux support for Easy Access and Internet Keyboards"
+HOMEPAGE="http://lineak.sourceforge.net"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libxkbfile
+ x11-libs/libXt
+ x11-libs/libXtst
+"
+
+S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-DELL-XPS-M1330-XOrg-1_5.patch
+)
+
+src_configure() {
+ econf $(use_enable debug) --with-x
+}
+
+src_install() {
+ sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' lineakd/Makefile
+
+ dodir /usr/share/man/man8
+
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc AUTHORS README TODO
+
+ keepdir /usr/$(get_libdir)/lineakd/plugins
+
+ insinto /etc/lineak
+ doins lineakd.conf.example lineakd.conf.kde.example
+
+ find "${ED}"/usr/share/man -name '*.bz2' -exec bunzip2 {} \; || die
+ find "${ED}" -name '*.la' -delete || die
+}