summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/magick-rotation
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/magick-rotation')
-rw-r--r--x11-misc/magick-rotation/Manifest1
-rw-r--r--x11-misc/magick-rotation/magick-rotation-1.6.2-r1.ebuild99
-rw-r--r--x11-misc/magick-rotation/metadata.xml18
3 files changed, 118 insertions, 0 deletions
diff --git a/x11-misc/magick-rotation/Manifest b/x11-misc/magick-rotation/Manifest
new file mode 100644
index 000000000000..5079cfb54ecf
--- /dev/null
+++ b/x11-misc/magick-rotation/Manifest
@@ -0,0 +1 @@
+DIST magick-rotation-1.6.2.tar.bz2 103389 SHA256 e0decb8ffb6bd5b8ffd0f01df345f23041abe78cda97fbe7065772260a1a2520 SHA512 40252c4b57d304244f8f7a8b08448cb498efd9044406235f2d728a89c8b4888009c4e7a9f50cbb61b5620336eedf1abb1591e68e94a57b051f4d823acbcdff5f WHIRLPOOL 3aeea34a2a7cbf966a7c0ea3bd13810e2a7a2015bc1f068566ce0515636bcb661e728af6682eea80b39624a3947a8219b9144a296f7c7fe9526d952d21cab49f
diff --git a/x11-misc/magick-rotation/magick-rotation-1.6.2-r1.ebuild b/x11-misc/magick-rotation/magick-rotation-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..ba4a60fb1596
--- /dev/null
+++ b/x11-misc/magick-rotation/magick-rotation-1.6.2-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+inherit eutils python-single-r1 toolchain-funcs udev user versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Application that rotates tablet pc's screen automatically, depending on orientation"
+HOMEPAGE="https://launchpad.net/magick-rotation"
+SRC_URI="http://launchpad.net/magick-rotation/trunk/${MY_PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ x11-libs/libX11
+ x11-libs/libXrandr"
+
+RDEPEND="${DEPEND}
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/py-notify[${PYTHON_USEDEP}]
+ x11-apps/xinput"
+
+# there are no tests in package, default 'make check' does wrong things, bug #453672
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ enewgroup magick
+}
+
+src_prepare() {
+ # Remove unneeded files
+ rm -r apt_* installer_gtk.py MAGICK-INSTALL gset_addkeyval.py MagickIcons/MagickSplash.png MagickUninstall || die 'removing unneeded files failed'
+
+ # Fix Python shebangs
+ python_fix_shebang "${S}"
+
+ epatch_user
+}
+
+src_compile() {
+ my_compile() {
+ echo $(tc-getCC) $*
+ $(tc-getCC) $* || die 'compilation failed'
+ }
+
+ local suffix=
+ if use amd64; then
+ suffix=64
+ else
+ suffix=32
+ fi
+ my_compile "${CFLAGS} ${LDFLAGS} check.c -lX11 -lXrandr -o checkmagick${suffix}"
+}
+
+src_install() {
+ #TODO: add installation of GNOME Shell 3.2 extension
+ dobin checkmagick*
+
+ udev_dorules 62-magick.rules
+
+ insinto /usr/share/${PN}
+ doins *.py
+
+ insinto /usr/share/${PN}/MagickIcons
+ doins MagickIcons/*.png
+
+ exeinto /usr/share/${PN}
+ doexe magick-rotation
+ doexe xrotate.py
+
+ dodoc *.txt ChangeLog
+
+ make_desktop_entry /usr/share/${PN}/${PN} "Magick Rotation" /usr/share/${PN}/MagickIcons/magick-rotation-enabled.png "System;Utility;"
+}
+
+pkg_postinst() {
+ optfeature() {
+ elog " [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1} (${2})"
+ }
+
+ elog
+ elog "In order to use Magick Rotation with an on-screen keyboard and handwriting,"
+ elog "the following additional package may also be installed for use at run-time:"
+ elog
+ optfeature 'media-gfx/cellwriter' "Magick Rotation's default onscreen keyboard"
+ elog
+
+ ewarn "in order to use Magick Rotation you have to be in the 'magick' group."
+ ewarn "Just run 'gpasswd -a <USER> magick', then have <USER> re-login."
+}
diff --git a/x11-misc/magick-rotation/metadata.xml b/x11-misc/magick-rotation/metadata.xml
new file mode 100644
index 000000000000..7e1cd0d686a6
--- /dev/null
+++ b/x11-misc/magick-rotation/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>evadim@evadim.ru</email>
+ <name>Vadim Efimov</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">magick-rotation</remote-id>
+ </upstream>
+</pkgmetadata>