summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-15 18:01:42 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-06-04 17:16:26 +0200
commit10957cb6a622830f7a11579e3076ebac9e773dda (patch)
treeb6cccc472e2c48cdbe09b83c6e1b74b72607ed05 /x11-misc/mate-notification-daemon/mate-notification-daemon-1.18.0.ebuild
parentx11-themes/mate-backgrounds: Version bump to 1.18.0 (diff)
downloadgentoo-10957cb6a622830f7a11579e3076ebac9e773dda.tar.gz
gentoo-10957cb6a622830f7a11579e3076ebac9e773dda.tar.bz2
gentoo-10957cb6a622830f7a11579e3076ebac9e773dda.zip
x11-misc/mate-notification-daemon: Version bump to 1.18.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-misc/mate-notification-daemon/mate-notification-daemon-1.18.0.ebuild')
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.18.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.18.0.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.18.0.ebuild
new file mode 100644
index 000000000000..d83471e84741
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.18.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.78:0
+ >=dev-libs/glib-2.36:2
+ >=sys-apps/dbus-1:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.14:3
+ >=x11-libs/libwnck-3:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ !x11-misc/notify-osd:*
+ !x11-misc/qtnotifydaemon:*
+ !x11-misc/notification-daemon:*"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}