summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-22 13:24:34 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:48:20 -0400
commit7bd899e4e9d793e0ce85210a45d404794deaa1d1 (patch)
tree1e24bdc4147074e908753a5e54bbe058a28d2253 /x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild
parentx11-themes/mate-backgrounds: Fix LICENSE (diff)
downloadgentoo-7bd899e4e9d793e0ce85210a45d404794deaa1d1.tar.gz
gentoo-7bd899e4e9d793e0ce85210a45d404794deaa1d1.tar.bz2
gentoo-7bd899e4e9d793e0ce85210a45d404794deaa1d1.zip
x11-misc/mate-notification-daemon: Bump to 1.24.0
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild')
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild
new file mode 100644
index 000000000000..b72fee0e8a41
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ virtual/libintl
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+ !x11-misc/notification-daemon
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-libs/libxml2
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}