summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-20 21:20:11 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-26 23:53:05 +0200
commit829bd74a5da67a35b70cef531c33ac8d34401d74 (patch)
treef14d9db33937eccbfcd837f1d0f8289836f58a1e /x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild
parentdev-db/clickhouse: unbundle librdkafka, lz4 and zstd (diff)
downloadgentoo-829bd74a5da67a35b70cef531c33ac8d34401d74.tar.gz
gentoo-829bd74a5da67a35b70cef531c33ac8d34401d74.tar.bz2
gentoo-829bd74a5da67a35b70cef531c33ac8d34401d74.zip
x11-misc/mixer_app: EAPI7, improve ebuild
Diffstat (limited to 'x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild')
-rw-r--r--x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild b/x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..45d98e6279df
--- /dev/null
+++ b/x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=Mixer.app-${PV}
+
+DESCRIPTION="mixer_app has volume controllers that can be configured to handle sound sources"
+HOMEPAGE="http://www.fukt.bsnet.se/~per/mixer/"
+SRC_URI="http://www.fukt.bsnet.se/~per/mixer/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog README )
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ tc-export CXX
+ emake
+}