summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-12 15:17:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-12 20:37:23 +0100
commit690326eefbcd517fafa99c1c1c812d47eb69bc9b (patch)
tree9a3699d171a37fc983baa70588f830e19d7b58c1 /x11-misc/pcmanfm-qt
parentx11-libs/libfm-qt: remove 0.14.1 (r0) (diff)
downloadgentoo-690326eefbcd517fafa99c1c1c812d47eb69bc9b.tar.gz
gentoo-690326eefbcd517fafa99c1c1c812d47eb69bc9b.tar.bz2
gentoo-690326eefbcd517fafa99c1c1c812d47eb69bc9b.zip
x11-misc/pcmanfm-qt: remove 'x11-libs/libfm' dependency
Upstream removed this completely in 0.14.0. - https://github.com/lxqt/libfm-qt/blob/master/CHANGELOG#L25 Closes: https://bugs.gentoo.org/680004 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/pcmanfm-qt')
-rw-r--r--x11-misc/pcmanfm-qt/pcmanfm-qt-0.14.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/pcmanfm-qt/pcmanfm-qt-0.14.1-r1.ebuild b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.14.1-r1.ebuild
new file mode 100644
index 000000000000..1c2abbd2c9bd
--- /dev/null
+++ b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.14.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Fast lightweight tabbed filemanager (Qt port)"
+HOMEPAGE="https://lxqt.org/"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ =x11-libs/libfm-qt-$(ver_cut 1-2)*
+ x11-libs/libxcb:=
+ x11-misc/xdg-utils
+ virtual/eject
+ virtual/freedesktop-icon-theme
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}