summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-07-20 20:45:18 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-07-22 15:05:34 +0200
commit4c0146398cf0fb2e43565e526a5d9cb68356dbbc (patch)
tree087573b1a1b770a5050ab7e9b3963cb201050a58 /x11-misc/qt5ct
parentapp-shells/mpv-bash-completion: remove old (diff)
downloadgentoo-4c0146398cf0fb2e43565e526a5d9cb68356dbbc.tar.gz
gentoo-4c0146398cf0fb2e43565e526a5d9cb68356dbbc.tar.bz2
gentoo-4c0146398cf0fb2e43565e526a5d9cb68356dbbc.zip
x11-misc/qt5ct: new package
This program allows users to configure Qt5 settings (theme, font, icons, etc.) under DE/WM without Qt5 integration. Gentoo-Bug: https://bugs.gentoo.org/577840 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/1926 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'x11-misc/qt5ct')
-rw-r--r--x11-misc/qt5ct/Manifest1
-rw-r--r--x11-misc/qt5ct/metadata.xml19
-rw-r--r--x11-misc/qt5ct/qt5ct-0.24.ebuild49
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-misc/qt5ct/Manifest b/x11-misc/qt5ct/Manifest
new file mode 100644
index 000000000000..d40141c3877d
--- /dev/null
+++ b/x11-misc/qt5ct/Manifest
@@ -0,0 +1 @@
+DIST qt5ct-0.24.tar.bz2 42427 SHA256 d7acba4e36ed6478a4a27a8cc9359b45f2ecdbcb5f46e6a19e6fdd4252b3c24c SHA512 670e518d8b927eb937bbde6e190dba735cdd7d833ada0299f18093b502ddda340b10d5ad6e6be94a7f08c46335ffb84128800c5625063c6614cb1248a00287c1 WHIRLPOOL d85528748440f3d14b68f9cc9bcade1a65e74918960918babf798ce9f7aa3f4c0661a6d59c43340276070882119b2be95a767f1f35f69adc98e52f137083576d
diff --git a/x11-misc/qt5ct/metadata.xml b/x11-misc/qt5ct/metadata.xml
new file mode 100644
index 000000000000..74362b492c50
--- /dev/null
+++ b/x11-misc/qt5ct/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ This program allows users to configure Qt5 settings (theme, font,
+ icons, etc.) under DE/WM without Qt5 integration.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">qt5ct</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/qt5ct/qt5ct-0.24.ebuild b/x11-misc/qt5ct/qt5ct-0.24.ebuild
new file mode 100644
index 000000000000..76b9a49a515c
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-0.24.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5=
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5=
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5 ${PN}.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ echo 'QT_QPA_PLATFORMTHEME=qt5ct' > "${T}"/98${PN} || die
+ doenvd "${T}"/98${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "qt5ct configuration won't be applied to the currently running sessions."
+ ewarn "Please relogin."
+ fi
+ if ! has_version 'dev-qt/qtsvg:5'; then
+ echo
+ elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+ echo
+ fi
+}