summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-01-27 22:31:53 +0300
committerMichael Palimaka <kensington@gentoo.org>2017-01-30 03:52:00 +1100
commit515573c7fc6890224549dfdc3788c23f5ecb6ab6 (patch)
tree7bbf77a353060df3857fd67f31481128377a8632 /x11-misc/qt5ct
parentapp-i18n/translate-shell: Bump (diff)
downloadgentoo-515573c7fc6890224549dfdc3788c23f5ecb6ab6.tar.gz
gentoo-515573c7fc6890224549dfdc3788c23f5ecb6ab6.tar.bz2
gentoo-515573c7fc6890224549dfdc3788c23f5ecb6ab6.zip
x11-misc/qt5ct: correctly apply KDE styles
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-misc/qt5ct')
-rw-r--r--x11-misc/qt5ct/files/qt5ct-0.29-fix-kde-styles.patch20
-rw-r--r--x11-misc/qt5ct/qt5ct-0.29-r1.ebuild (renamed from x11-misc/qt5ct/qt5ct-0.29.ebuild)2
2 files changed, 22 insertions, 0 deletions
diff --git a/x11-misc/qt5ct/files/qt5ct-0.29-fix-kde-styles.patch b/x11-misc/qt5ct/files/qt5ct-0.29-fix-kde-styles.patch
new file mode 100644
index 000000000000..d15609d24c75
--- /dev/null
+++ b/x11-misc/qt5ct/files/qt5ct-0.29-fix-kde-styles.patch
@@ -0,0 +1,20 @@
+Correctly apply selected theme to KDE apps.
+
+https://sourceforge.net/p/qt5ct/tickets/32/
+
+Index: src/qt5ct-qtplugin/qt5ctplatformtheme.cpp
+===================================================================
+--- a/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (revision 368)
++++ b/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (revision 369)
+@@ -101,9 +101,8 @@
+
+ const QPalette *Qt5CTPlatformTheme::palette(QPlatformTheme::Palette type) const
+ {
+- if(m_customPalette && m_usePalette)
+- return m_customPalette;
+- return QPlatformTheme::palette(type);
++ Q_UNUSED(type);
++ return (m_usePalette ? m_customPalette : 0);
+ }
+
+ const QFont *Qt5CTPlatformTheme::font(QPlatformTheme::Font type) const
diff --git a/x11-misc/qt5ct/qt5ct-0.29.ebuild b/x11-misc/qt5ct/qt5ct-0.29-r1.ebuild
index c449014e4639..2563ebe254f2 100644
--- a/x11-misc/qt5ct/qt5ct-0.29.ebuild
+++ b/x11-misc/qt5ct/qt5ct-0.29-r1.ebuild
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
"
+PATCHES=( "${FILESDIR}/${P}-fix-kde-styles.patch" )
+
src_configure() {
eqmake5 DEFINES="$(usex systray '' QT_NO_SYSTEMTRAYICON)" ${PN}.pro
}