summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-09 15:46:33 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-09 15:46:47 +0200
commit9f4dd94a3978cd6f7aa8aa1682e2574583db97d6 (patch)
tree714c264d54307898091b6640b8416ca69dd94d16 /x11-misc/qtfm/files
parentgames-strategy/s25rttr: remove arch detection via cmake (diff)
downloadgentoo-9f4dd94a3978cd6f7aa8aa1682e2574583db97d6.tar.gz
gentoo-9f4dd94a3978cd6f7aa8aa1682e2574583db97d6.tar.bz2
gentoo-9f4dd94a3978cd6f7aa8aa1682e2574583db97d6.zip
x11-misc/qtfm: Add live ebuild
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/qtfm/files')
-rw-r--r--x11-misc/qtfm/files/qtfm-99999-cmake.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/qtfm/files/qtfm-99999-cmake.patch b/x11-misc/qtfm/files/qtfm-99999-cmake.patch
new file mode 100644
index 000000000000..a89d090510df
--- /dev/null
+++ b/x11-misc/qtfm/files/qtfm-99999-cmake.patch
@@ -0,0 +1,47 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -36,7 +36,7 @@
+ add_definitions(-DMAGICK7)
+ endif()
+ find_package(PkgConfig REQUIRED)
+- pkg_check_modules(MAGICK REQUIRED ImageMagick++)
++ pkg_check_modules(MAGICK REQUIRED Magick++)
+ # ffmpeg
+ if(ENABLE_FFMPEG)
+ pkg_check_modules(AVDEVICE REQUIRED libavdevice)
+@@ -66,7 +66,7 @@
+ find_package(Qt5Concurrent REQUIRED)
+
+ # inotify
+-if("${CMAKE_SYSTEM}" NOT MATCHES "Linux")
++if(NOT "${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+ find_package(PkgConfig REQUIRED)
+ pkg_check_modules(NOTIFY REQUIRED libinotify)
+ endif()
+@@ -123,7 +123,7 @@
+ ${PROJECT_VERSION_MAJOR}
+ )
+ if(ENABLE_MAGICK OR ENABLE_MAGICK7)
+- target_compile_definitions(QtFM PRIVATE ${MAGICK_CFLAGS_OTHER})
++ target_compile_options(QtFM PRIVATE ${MAGICK_CFLAGS_OTHER})
+ target_link_libraries(QtFM ${MAGICK_LIBRARIES})
+ if(ENABLE_FFMPEG)
+ target_include_directories(QtFM
+@@ -161,7 +161,7 @@
+ if(ENABLE_DBUS)
+ target_link_libraries(QtFM Qt5::DBus QtFMBus)
+ endif()
+-if("${CMAKE_SYSTEM}" NOT MATCHES "Linux")
++if(NOT "${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+ target_link_libraries(QtFM ${NOTIFY_LIBRARIES})
+ endif()
+ if(APPLE)
+@@ -192,7 +192,7 @@
+ if(ENABLE_DBUS)
+ target_link_libraries(${PROJECT_NAME} Qt5::DBus)
+ endif()
+-if("${CMAKE_SYSTEM}" NOT MATCHES "Linux")
++if(NOT "${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+ target_link_libraries(${PROJECT_NAME} ${NOTIFY_LIBRARIES})
+ endif()
+ if(APPLE)