summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-03-01 19:15:58 +0200
committerDavid Seifert <soap@gentoo.org>2017-03-01 21:45:03 +0100
commite99d866b8329530451a2d38d7f470d59c33fcb52 (patch)
tree7b18be51fd76c853a76762193c1075628d91641f /x11-misc/qtfm
parentx11-misc/qps: EAPI bump 4 -> 6 (diff)
downloadgentoo-e99d866b8329530451a2d38d7f470d59c33fcb52.tar.gz
gentoo-e99d866b8329530451a2d38d7f470d59c33fcb52.tar.bz2
gentoo-e99d866b8329530451a2d38d7f470d59c33fcb52.zip
x11-misc/qtfm: EAPI bump 4 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4091
Diffstat (limited to 'x11-misc/qtfm')
-rw-r--r--x11-misc/qtfm/qtfm-5.5-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/qtfm/qtfm-5.5-r1.ebuild b/x11-misc/qtfm/qtfm-5.5-r1.ebuild
new file mode 100644
index 000000000000..eaff4fb11c71
--- /dev/null
+++ b/x11-misc/qtfm/qtfm-5.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit fdo-mime qmake-utils
+
+DESCRIPTION="A small, lightweight file manager for desktops based on pure Qt"
+HOMEPAGE="http://www.qtfm.org/"
+SRC_URI="http://www.qtfm.org/${P}.tar.gz?attredirects=0 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# file is for LIBS += -lmagic
+RDEPEND="sys-apps/file
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^docs.path/s:qtfm:${PF}:" \
+ -e '/^docs.files/s: COPYING::' \
+ ${PN}.desktop || die
+ sed -i \
+ -e '/MimeType=/s|$|;|' \
+ -e '/Categories=/s|$|;System;FileTools;|' \
+ ${PN}.desktop || die
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}