summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-29 11:50:26 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-29 12:32:05 +0100
commit353a59910102231bbb60fe5735251d57c64782f0 (patch)
tree369363d92cbb7dba6ca1abe9b2da937297141872 /x11-misc/read-edid
parentdev-python/pyparted: Set CFLAGS=-fcommon (diff)
downloadgentoo-353a59910102231bbb60fe5735251d57c64782f0.tar.gz
gentoo-353a59910102231bbb60fe5735251d57c64782f0.tar.bz2
gentoo-353a59910102231bbb60fe5735251d57c64782f0.zip
x11-misc/read-edid: Set CFLAGS=-fcommon
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=706878 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/read-edid')
-rw-r--r--x11-misc/read-edid/read-edid-3.0.2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/x11-misc/read-edid/read-edid-3.0.2.ebuild b/x11-misc/read-edid/read-edid-3.0.2.ebuild
index f55ccb264aa2..cef6d33015a8 100644
--- a/x11-misc/read-edid/read-edid-3.0.2.ebuild
+++ b/x11-misc/read-edid/read-edid-3.0.2.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
DESCRIPTION="Program that can get information from a PnP monitor"
HOMEPAGE="http://www.polypux.org/projects/read-edid/"
@@ -21,3 +20,8 @@ src_prepare() {
CMakeLists.txt || die
cmake-utils_src_prepare
}
+
+src_configure() {
+ append-cflags -fcommon
+ cmake-utils_src_configure
+}