summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-06 21:38:01 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-06 21:38:24 +0200
commitb9920a88b239a832e3297cc95a1ab25245376386 (patch)
tree29e045fc7414944a57a18f46052ac7c8d8f52343 /x11-misc/rofi
parentapp-admin/salt-3001.1-r1: Revbump, pycryptodomex dep (bug #740388) (diff)
downloadgentoo-b9920a88b239a832e3297cc95a1ab25245376386.tar.gz
gentoo-b9920a88b239a832e3297cc95a1ab25245376386.tar.bz2
gentoo-b9920a88b239a832e3297cc95a1ab25245376386.zip
x11-misc/rofi: Version 1.6.0
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/rofi')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/metadata.xml11
-rw-r--r--x11-misc/rofi/rofi-1.6.0.ebuild56
3 files changed, 63 insertions, 5 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index d793eeb10deb..f2d32aab71ae 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1 +1,2 @@
DIST rofi-1.5.4.tar.gz 535259 BLAKE2B 8560dfee631c66a6f2178c0af6926ef317ed6d2cfe3ae46264e5b1ce429113ce810e4fed4c86a81acbbd51c85ad2593f40a39d982d7da0aa8ccc55537cadd2bb SHA512 181dedb0905bfab76f7ad313d299f4c80ee4efb11a2c6345b16044b7fb3f54bc7e304ee9352e562932e55108e328e5f6bd2c1d7fd9bcdec3d8022c2dc4f8d394
+DIST rofi-1.6.0.tar.gz 558808 BLAKE2B 45849f71becd3ab69b85dae64af34ad42199c20976304b89b013405f1d7fbbfa8fdf7d3ac4c26563cc2f5924fad64d45da1ba7dcad8857fb127eaf4b40c08824 SHA512 a993b0d49681eae4bc4aa84277f6daf1467e53bc40fa43e97ccf3f834763a3c9a1ed8b5d1d628158febc9e8b339be3fb745ae5b4e1d86e9f84b7af4b6a30ea23
diff --git a/x11-misc/rofi/metadata.xml b/x11-misc/rofi/metadata.xml
index d9dc616fbbc3..55134acf088d 100644
--- a/x11-misc/rofi/metadata.xml
+++ b/x11-misc/rofi/metadata.xml
@@ -2,16 +2,17 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>jer@gentoo.org</email>
+<email>jer@gentoo.org</email>
</maintainer>
<maintainer type="project">
- <email>desktop-misc@gentoo.org</email>
- <name>Gentoo Desktop Miscellaneous Project</name>
+<email>desktop-misc@gentoo.org</email>
+<name>Gentoo Desktop Miscellaneous Project</name>
</maintainer>
<use>
- <flag name="windowmode">Enable normal window mode</flag>
+<flag name="drun">Enable desktop file run dialog</flag>
+<flag name="windowmode">Enable normal window mode</flag>
</use>
<upstream>
- <remote-id type="github">DaveDavenport/rofi</remote-id>
+<remote-id type="github">DaveDavenport/rofi</remote-id>
</upstream>
</pkgmetadata>
diff --git a/x11-misc/rofi/rofi-1.6.0.ebuild b/x11-misc/rofi/rofi-1.6.0.ebuild
new file mode 100644
index 000000000000..135a161cf38e
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+ "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable drun) \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}