summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/set_opacity
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/set_opacity')
-rw-r--r--x11-misc/set_opacity/Manifest1
-rw-r--r--x11-misc/set_opacity/files/makefile.patch21
-rw-r--r--x11-misc/set_opacity/metadata.xml11
-rw-r--r--x11-misc/set_opacity/set_opacity-1.0.ebuild32
-rw-r--r--x11-misc/set_opacity/set_opacity-9999.ebuild33
5 files changed, 98 insertions, 0 deletions
diff --git a/x11-misc/set_opacity/Manifest b/x11-misc/set_opacity/Manifest
new file mode 100644
index 000000000000..b0519b9e37d8
--- /dev/null
+++ b/x11-misc/set_opacity/Manifest
@@ -0,0 +1 @@
+DIST set_opacity-1.0.tar.gz 5115 SHA256 b3aac6b47107840866f1968e346f59963de2548d7d583a919c95144cb7aae105
diff --git a/x11-misc/set_opacity/files/makefile.patch b/x11-misc/set_opacity/files/makefile.patch
new file mode 100644
index 000000000000..bb21db68ce48
--- /dev/null
+++ b/x11-misc/set_opacity/files/makefile.patch
@@ -0,0 +1,21 @@
+--- Makefile 2006-02-09 16:45:52.000000000 +0300
++++ Makefile 2011-07-18 13:58:58.644703015 +0400
+@@ -1,14 +1,14 @@
+ PACKAGES = xcomposite xfixes xdamage xrender
+-LIBS=`pkg-config --libs ${PACKAGES}` -lm
+-INCS=`pkg-config --cflags ${PACKAGES}`
++LIBS=$(shell pkg-config --libs $(PACKAGES)) -lm
++INCS=$(shell pkg-config --cflags $(PACKAGES))
+
+ .c.o:
+- $(CC) $(CFLAGS) $(INCS) -c $*.c
++ $(CC) $(CFLAGS) $(INCS) -c $< -o $@
+
+ OBJS=set_opacity.o interface.o stack.o
+
+ set_opacity: $(OBJS)
+- $(CC) $(CFLAGS) -g -o $@ $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ $(OBJS): interface.h stack.h
+
diff --git a/x11-misc/set_opacity/metadata.xml b/x11-misc/set_opacity/metadata.xml
new file mode 100644
index 000000000000..57147d064d19
--- /dev/null
+++ b/x11-misc/set_opacity/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitorious">x11-tools/set_opacity</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/set_opacity/set_opacity-1.0.ebuild b/x11-misc/set_opacity/set_opacity-1.0.ebuild
new file mode 100644
index 000000000000..37a6cba55d5c
--- /dev/null
+++ b/x11-misc/set_opacity/set_opacity-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
+HOMEPAGE="https://gitorious.org/x11-tools/set_opacity"
+SRC_URI="https://gitorious.org/x11-tools/set_opacity/archive-tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXdamage
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXrender"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/x11-tools-set_opacity"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin set_opacity
+}
diff --git a/x11-misc/set_opacity/set_opacity-9999.ebuild b/x11-misc/set_opacity/set_opacity-9999.ebuild
new file mode 100644
index 000000000000..6633e1570170
--- /dev/null
+++ b/x11-misc/set_opacity/set_opacity-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+EGIT_REPO_URI="git://gitorious.org/x11-tools/set_opacity.git"
+
+inherit git-2 toolchain-funcs
+
+DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
+HOMEPAGE="https://gitorious.org/x11-tools/set_opacity"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libXdamage
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXrender"
+RDEPEND=${DEPEND}
+
+KEYWORDS=""
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin set_opacity
+}