summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-01-28 11:10:03 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-01-28 11:15:48 +0300
commit0f35eaef18ee050158ef38cc6d8123a500e3191d (patch)
treed7f1b8fe27a533d71a521b9b9597383cabe65f96 /x11-misc/simple-ccsm
parentsys-kernel/vanilla-sources: Automated version bump to {3.12.53,3.18.26} - rem... (diff)
downloadgentoo-0f35eaef18ee050158ef38cc6d8123a500e3191d.tar.gz
gentoo-0f35eaef18ee050158ef38cc6d8123a500e3191d.tar.bz2
gentoo-0f35eaef18ee050158ef38cc6d8123a500e3191d.zip
Move x11-apps/ccsm and x11-apps/simple-ccsm to x11-misc/ccsm and
x11-misc/simple-ccsm respectively Gentoo-Bug: 571838 Gentoo-Bug: 571852
Diffstat (limited to 'x11-misc/simple-ccsm')
-rw-r--r--x11-misc/simple-ccsm/Manifest1
-rw-r--r--x11-misc/simple-ccsm/metadata.xml9
-rw-r--r--x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild54
3 files changed, 64 insertions, 0 deletions
diff --git a/x11-misc/simple-ccsm/Manifest b/x11-misc/simple-ccsm/Manifest
new file mode 100644
index 000000000000..821bd0a4a4ab
--- /dev/null
+++ b/x11-misc/simple-ccsm/Manifest
@@ -0,0 +1 @@
+DIST simple-ccsm-0.8.4.tar.bz2 62423 SHA256 15b24408be48f1e3c69735362dd65ea6b3ddded80e63b87ec40268e2f0f652a3 SHA512 f60a689e18fcea494eacc4eaa8718d77b846af6790cb5de056ecd432fd8b5190ebd4ce6669744b3da408e492f68012503f420e28e66be83b747b2e532b152158 WHIRLPOOL 32cd613ac9ed2e82eb6aa61291824d782a3b3fd7758b36e13cbe0ec28007f3633a95cdaa0fce00db720795039cd73b7244f1100f80ad933a67e21cd498f6f421
diff --git a/x11-misc/simple-ccsm/metadata.xml b/x11-misc/simple-ccsm/metadata.xml
new file mode 100644
index 000000000000..43da4805e440
--- /dev/null
+++ b/x11-misc/simple-ccsm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>desktop-effects@gentoo.org</email>
+ <name>Desktop effects</name>
+</maintainer>
+<longdescription lang="en">Simplified Compizconfig Settings Manager.</longdescription>
+</pkgmetadata>
diff --git a/x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild b/x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
new file mode 100644
index 000000000000..ef064ce75604
--- /dev/null
+++ b/x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="Simplified Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+RDEPEND="
+ >=dev-python/compizconfig-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
+ >=x11-apps/ccsm-${PV}[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # return error if wrong arguments passed to setup.py
+ sed -i -e 's/raise SystemExit/\0(1)/' setup.py || die 'sed on setup.py failed'
+ # fix desktop file
+ sed -i \
+ -e '/Categories/s/Compiz/X-\0/' \
+ -e '/Encoding/d' \
+ "${PN}".desktop.in || die "sed on ${PN}.desktop.in failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=( build --prefix=/usr )
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}