summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-07-25 10:36:41 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-07-25 10:38:57 -0400
commit128e5981559b7760c537e43574f5936648e236d4 (patch)
tree8352e1360def759e4ee4a78a587616447f2b53c9 /x11-misc/slim/slim-1.3.6-r5.ebuild
parentdev-php/pecl-ps: Version bump to new slot for PHP 7 (diff)
downloadgentoo-128e5981559b7760c537e43574f5936648e236d4.tar.gz
gentoo-128e5981559b7760c537e43574f5936648e236d4.tar.bz2
gentoo-128e5981559b7760c537e43574f5936648e236d4.zip
x11-misc/slim: process ${REPLACING_VERSIONS} as a list
Bug: http://bugs.gentoo.org/589540 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-misc/slim/slim-1.3.6-r5.ebuild')
-rw-r--r--x11-misc/slim/slim-1.3.6-r5.ebuild22
1 files changed, 19 insertions, 3 deletions
diff --git a/x11-misc/slim/slim-1.3.6-r5.ebuild b/x11-misc/slim/slim-1.3.6-r5.ebuild
index 7e79bb00de51..53e9a60f20a7 100644
--- a/x11-misc/slim/slim-1.3.6-r5.ebuild
+++ b/x11-misc/slim/slim-1.3.6-r5.ebuild
@@ -90,15 +90,31 @@ src_install() {
}
pkg_postinst() {
- # note, $REPLACING_VERSIONS will always contain 0 or 1 PV's for slim
- if [[ -z ${REPLACING_VERSIONS} ]]; then
+ # massage ${REPLACING_VERSIONS} to come up with whether or not it's a new install
+ # or if it's older than 1.3.2-r7
+ # Note - there should only ever be zero or one version as this package isn't slotted,
+ # so the logic doesn't worry about what happens if there's two, due to the case where
+ # a previous emerge attempt failed in the middle of qmerge.
+ local rv=none
+ for rv in ${REPLACING_VERSIONS} ; do
+ if version_is_at_least "1.3.2-r7" "${rv}" ; then
+ rv=newer
+ break;
+ fi
+ if version_is_at_least "1.0" "${rv}" ; then
+ rv=older
+ break;
+ fi
+ done
+
+ if [[ ${rv} == none ]]; then
elog
elog "The configuration file is located at /etc/slim.conf."
elog
elog "If you wish ${PN} to start automatically, set DISPLAYMANAGER=\"${PN}\" "
elog "in /etc/conf.d/xdm and run \"rc-update add xdm default\"."
fi
- if ! version_is_at_least "1.3.2-r7" "${REPLACING_VERSIONS:-1.0}" ; then
+ if [[ ${rv} != newer ]]; then
elog
elog "By default, ${PN} is set up to do proper X session selection, including ~/.xsession"
elog "support, as well as selection between sessions available in"