summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngolf Wagner <contact@ingolf-wagner.de>2016-12-21 21:38:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-04 23:55:52 +0200
commit676abc6970aa6853a0220206c174be170bee3070 (patch)
tree416ea8e71c8278a2a3bbe984d41ec81751baa29e /x11-misc/slop
parentsys-apps/sysvinit: block <sys-apps/openrc-0.13 (diff)
downloadgentoo-676abc6970aa6853a0220206c174be170bee3070.tar.gz
gentoo-676abc6970aa6853a0220206c174be170bee3070.tar.bz2
gentoo-676abc6970aa6853a0220206c174be170bee3070.zip
x11-misc/slop: add new package
Closes: https://github.com/gentoo/gentoo/pull/2796
Diffstat (limited to 'x11-misc/slop')
-rw-r--r--x11-misc/slop/Manifest1
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch20
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch33
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-librt.patch37
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-opengl.patch18
-rw-r--r--x11-misc/slop/metadata.xml21
-rw-r--r--x11-misc/slop/slop-4.3.21.ebuild50
7 files changed, 180 insertions, 0 deletions
diff --git a/x11-misc/slop/Manifest b/x11-misc/slop/Manifest
new file mode 100644
index 000000000000..e002bc62316e
--- /dev/null
+++ b/x11-misc/slop/Manifest
@@ -0,0 +1 @@
+DIST slop-4.3.21.tar.gz 488238 SHA256 352eb367a8d11686adb182c7dbddf65d55b0ee4d5a2257a07486d5728722177c SHA512 4489a108883b785eb5dda368a06ea0b7c61e3afeefdeb421f211e01e3cb7eb20836200197abc755be653f086fcd3b8647a460dacf15062fe2cd44438b4f54b68 WHIRLPOOL 651d5c736fd4a8431fd9967280181c8512a4948c9534d73cc8c035cf9a925dffc22e966ffed79421ec2e1fae1c6008af4e6cac7413a8efe45a8f5f2e8f6113e2
diff --git a/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch b/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch
new file mode 100644
index 000000000000..f92c57f977df
--- /dev/null
+++ b/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch
@@ -0,0 +1,20 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 361f930..0982647 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -33,15 +33,6 @@ else()
+ message( FATAL_ERROR "Your operating system isn't supported yet! CMake will now exit." )
+ endif()
+
+-# Add a check target for our makefile.
+-find_program( CPPCHECK_EXECUTABLE cppcheck
+- DOC "A tool for static C/C++ code analysis." )
+-if (CPPCHECK_EXECUTABLE)
+- add_custom_target( "check"
+- COMMAND "${CPPCHECK_EXECUTABLE}" "--enable=all" "*"
+- WORKING_DIRECTORY src VERBATIM )
+-endif()
+-
+ # Here we generate some of our code if we can. I package it pre-generated
+ # so nobody has to go find and install gengetopt if they don't want to.
+ find_program( GENGETOPT_EXECUTABLE gengetopt
diff --git a/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch b/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch
new file mode 100644
index 000000000000..13f79eef2110
--- /dev/null
+++ b/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch
@@ -0,0 +1,33 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -33,29 +33,6 @@ else()
+ message( FATAL_ERROR "Your operating system isn't supported yet! CMake will now exit." )
+ endif()
+
+-# Here we generate some of our code if we can. I package it pre-generated
+-# so nobody has to go find and install gengetopt if they don't want to.
+-find_program( GENGETOPT_EXECUTABLE gengetopt
+- DOC "A tool to generate code to grab command line options." )
+-find_program( SED_EXECUTABLE sed )
+-if ( GENGETOPT_EXECUTABLE AND SED_EXECUTABLE )
+- message( "-- Regenerating cmdline.in" )
+- # gengetopt generates cmdline.h, then we move it to cmdline.in.
+- execute_process( COMMAND "${GENGETOPT_EXECUTABLE}" "--input=options.ggo"
+- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
+- file( RENAME "${CMAKE_CURRENT_SOURCE_DIR}/src/cmdline.h" "${CMAKE_CURRENT_SOURCE_DIR}/src/cmdline.in" )
+- # Due to a bug in gengetopt, we have to manually insert some code.
+- # Replace the first instance of REPLACEME with some text.
+- # Eight backslashes = two in the code because of how many instances of escaping is happening.
+- execute_process( COMMAND "${SED_EXECUTABLE}" "-i" "0,/REPLACEME/{s/REPLACEME/X=%x\\\\\\\\nY=%y\\\\\\\\nW=%w\\\\\\\\nH=%h\\\\\\\\nG=%g\\\\\\\\nID=%i\\\\\\\\nCancel=%c\\\\\\\\n/}" "cmdline.c"
+- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
+- # Then replace remaining instances.
+- execute_process( COMMAND "${SED_EXECUTABLE}" "-i" "s/REPLACEME/X=%x\\\\nY=%y\\\\nW=%w\\\\nH=%h\\\\nG=%g\\\\nID=%i\\\\nCancel=%c\\\\n/" "cmdline.c"
+- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
+-else()
+- message( "Warning: Command gengetopt or sed not found! Won't regenerate command line code. (If you're just compiling this doesn't matter.)" )
+-endif()
+-
+ # By default our src/options.ggo has our cmake versions variables for
+ # the 'version ""' line. We replace them here.
+ # The ${CMAKE_SOURCE_DIR} is there to fix problems with OpenBSD's out-of-source build black magic.
diff --git a/x11-misc/slop/files/slop-4.3.21-no-librt.patch b/x11-misc/slop/files/slop-4.3.21-no-librt.patch
new file mode 100644
index 000000000000..0b95b833ffda
--- /dev/null
+++ b/x11-misc/slop/files/slop-4.3.21-no-librt.patch
@@ -0,0 +1,37 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -75,10 +75,6 @@ find_package( GLX REQUIRED )
+ find_package( XRender REQUIRED )
+ find_package( XRandr REQUIRED )
+ find_package( GLEW REQUIRED )
+-# This library is needed only for Ubuntu it seems, some platforms don't even
+-# ship with it. I couldn't find a way to do a test compile to check if librt
+-# was needed, so instead I just didn't mark it as REQUIRED.
+-find_package( RT )
+
+ set( CMAKE_CXX_FLAGS
+ "${CMAKE_CXX_FLAGS} ${CMAKE_IMLIB2_CXX_FLAGS}" )
+@@ -96,10 +92,6 @@ include_directories( "${IMLIB2_INCLUDE_DIR}"
+ ${XRENDER_INCLUDE_DIRS} )
+ endif()
+
+-if ( RT_INCLUDE_DIR )
+- include_directories( ${RT_INCLUDE_DIR} )
+-endif()
+-
+ # Executable
+ add_executable( "${BIN_TARGET}" ${source} )
+
+@@ -119,11 +111,6 @@ if ( CMAKE_OPENGL_SUPPORT )
+ endif()
+
+
+-if ( RT_LIBRARY )
+- target_link_libraries( "${BIN_TARGET}"
+- "${RT_LIBRARY}" )
+-endif()
+-
+ install( TARGETS ${BIN_TARGET}
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/bin" )
+
diff --git a/x11-misc/slop/files/slop-4.3.21-no-opengl.patch b/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
new file mode 100644
index 000000000000..7dbd45dd7d00
--- /dev/null
+++ b/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
@@ -0,0 +1,18 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -67,14 +67,8 @@ endif()
+
+ # Obtain library paths and make sure they exist.
+ set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmakemodules" )
+-find_package( Imlib2 REQUIRED )
+ find_package( X11 REQUIRED )
+ find_package( XExt REQUIRED )
+-find_package( OpenGL REQUIRED )
+-find_package( GLX REQUIRED )
+-find_package( XRender REQUIRED )
+-find_package( XRandr REQUIRED )
+-find_package( GLEW REQUIRED )
+
+ set( CMAKE_CXX_FLAGS
+ "${CMAKE_CXX_FLAGS} ${CMAKE_IMLIB2_CXX_FLAGS}" )
diff --git a/x11-misc/slop/metadata.xml b/x11-misc/slop/metadata.xml
new file mode 100644
index 000000000000..a8520d04c756
--- /dev/null
+++ b/x11-misc/slop/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@ingolf-wagner.de</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ slop (Select Operation) is an application that queries for a selection
+ from the user and prints the region to stdout. It grabs the mouse and
+ turns it into a crosshair, lets the user click and drag to make a
+ selection (or click on a window) while drawing a pretty box around it,
+ then finally prints the selection's dimensions to stdout.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">naelstrof/slop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/slop/slop-4.3.21.ebuild b/x11-misc/slop/slop-4.3.21.ebuild
new file mode 100644
index 000000000000..2a90460ad597
--- /dev/null
+++ b/x11-misc/slop/slop-4.3.21.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An application that queries the user for a selection for printing"
+HOMEPAGE="https://github.com/naelstrof/slop"
+SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ opengl? (
+ media-libs/glew:0=
+ media-libs/imlib2
+ virtual/opengl
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ )"
+DEPEND="
+ ${RDEPEND}
+ opengl? (
+ media-libs/glm
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.3.21-no-cppcheck.patch"
+ "${FILESDIR}/${PN}-4.3.21-no-gengetopt.patch"
+ "${FILESDIR}/${PN}-4.3.21-no-librt.patch"
+)
+
+src_prepare() {
+ use opengl || PATCHES+=( "${FILESDIR}/${PN}-4.3.21-no-opengl.patch" )
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_OPENGL_SUPPORT=$(usex opengl)
+ )
+ cmake-utils_src_configure
+}