summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-12-25 21:10:48 +0100
committerAmy Liffey <amynka@gentoo.org>2018-12-25 21:12:47 +0100
commit3ff042c52f23d6ceeb911ed866d2681ba299ff23 (patch)
treed2c5e76b99246eadb504ca8b42f4f97867dc9893 /x11-misc/tint2
parentnet-mail/mpop: remove old (diff)
downloadgentoo-3ff042c52f23d6ceeb911ed866d2681ba299ff23.tar.gz
gentoo-3ff042c52f23d6ceeb911ed866d2681ba299ff23.tar.bz2
gentoo-3ff042c52f23d6ceeb911ed866d2681ba299ff23.zip
x11-misc/tint2: version bump 16.6.1
Closes: https://bugs.gentoo.org/673726 Signed-off-by: Amy Liffey <amynka@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'x11-misc/tint2')
-rw-r--r--x11-misc/tint2/Manifest1
-rw-r--r--x11-misc/tint2/tint2-16.6.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/tint2/Manifest b/x11-misc/tint2/Manifest
index 2fd4826ff46d..6995713920a1 100644
--- a/x11-misc/tint2/Manifest
+++ b/x11-misc/tint2/Manifest
@@ -3,4 +3,5 @@ DIST tint2-0.14.6.tar.gz 466533 BLAKE2B c7308771e8a5a7d49410d99779ee54fd19b7d5b7
DIST tint2-15.3.tar.gz 500301 BLAKE2B b8b405f1c56c3de41f672dc02acef893b0650fadca9a4823c7b249661e8675e01c92c9c1588d32c2836596f34c4dbc1e5d2608cff3c75590d7eeac9e925eb874 SHA512 41ae8f8e3aac6fe55539c531889ec2883534072ad398f0693e4bfd39c80dd4c64d635a36e063f741fe89fd461f66f92adf6acdde553e0f8b169992d94dc0e344
DIST tint2-16.1.tar.gz 534354 BLAKE2B 540287bd952ba8b54372d45055efe216dc4d9d192e33d6f83f2c734e97b9e350c7be0cb3e19d414f4e11c0bb7b505307899dea9c10ac382737a2507f7df4fdcc SHA512 c6319d5692d53e56c150906c32c794ee4237e06455efb68527b379b4ae00c48d996c63ea02ee6aefc70266335eb4cb08b4731556075c46d435b7861de6eefd3c
DIST tint2-16.2.tar.gz 537236 BLAKE2B b8ff236f4c21465603c3cdf1e3d9f62e238cfbd05fbb7976e4f90ac054566eb433d8be78ee657421b94465dceeb8461ace202090b08585693f13003d401e4faf SHA512 0e267d59aef3d812ab41c1e5904e3e96162afd8d98c76dc697fe8c2815707f34a31e392f68260311bdc66fcb4c0b1766ad549ff30d4314e6ab2e2debf069cafe
+DIST tint2-16.6.1.tar.gz 546590 BLAKE2B 0e970293b09ba766d795b7bc454f06c7a9e95a7c3534144583f5739fd275d3fee2568677f24b5d9b0809ebbc466351cfa17f91dbb726f5cdae3a0bdc9b9df16f SHA512 ae3b8c7b1573f7bb993a587a125341e4018ace605b4b357a7d633beb02e7622443b92cd11b95028d4704e94211ae9f2e13e89cd3bca91474e7daba2fb9fc2b46
DIST tint2-16.6.tar.gz 546960 BLAKE2B 083e29d754c1faa9eff50dc480d18df99d64f44a2f88673f06e659d55de13c074eacf4614a57211d5b5aeec3a10f3d68471212d24a7280020b52fe91777d305d SHA512 f81770f330d3f2462292f726a6a90ac0182c518b2db7d79f098babe52863e5ceaf4293f975708f83fbc26735c79fdfefd110102ef0f4be45ae242b4f664d72b1
diff --git a/x11-misc/tint2/tint2-16.6.1.ebuild b/x11-misc/tint2/tint2-16.6.1.ebuild
new file mode 100644
index 000000000000..5a5f9d056fd8
--- /dev/null
+++ b/x11-misc/tint2/tint2-16.6.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils vcs-snapshot
+
+DESCRIPTION="tint2 is a lightweight panel/taskbar for Linux."
+HOMEPAGE="https://gitlab.com/o9000/tint2"
+SRC_URI="https://gitlab.com/o9000/${PN}/repository/archive.tar.gz?ref=v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="battery svg startup-notification tint2conf"
+
+DEPEND="
+ dev-libs/glib:2
+ svg? ( gnome-base/librsvg:2 )
+ >=media-libs/imlib2-1.4.2[X,png]
+ x11-libs/cairo[X]
+ x11-libs/pango
+ tint2conf? ( x11-libs/gtk+:2 )
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXrender
+ startup-notification? ( x11-libs/startup-notification )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -DENABLE_BATTERY="$(usex battery)"
+ -DENABLE_TINT2CONF="$(usex tint2conf)"
+ -DENABLE_SN="$(usex startup-notification)"
+ -DENABLE_RSVG="$(usex svg)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}