summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-18 14:41:31 +0100
committerJeroen Roovers <jer@gentoo.org>2017-03-18 14:42:37 +0100
commit7c76bc1cc378eed2832fc9f557156e238b911f69 (patch)
tree0c3f500ced9a6edaaaef2b27cbabc3a645962581 /x11-misc/treeline
parentmail-client/roundcube: Bump to v1.2.4 (diff)
downloadgentoo-7c76bc1cc378eed2832fc9f557156e238b911f69.tar.gz
gentoo-7c76bc1cc378eed2832fc9f557156e238b911f69.tar.bz2
gentoo-7c76bc1cc378eed2832fc9f557156e238b911f69.zip
x11-misc/treeline: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'x11-misc/treeline')
-rw-r--r--x11-misc/treeline/Manifest3
-rw-r--r--x11-misc/treeline/treeline-2.0.2.ebuild39
-rw-r--r--x11-misc/treeline/treeline-2.1.1.ebuild (renamed from x11-misc/treeline/treeline-1.9.4.ebuild)2
3 files changed, 42 insertions, 2 deletions
diff --git a/x11-misc/treeline/Manifest b/x11-misc/treeline/Manifest
index 9feced7c1d8d..8dbd6e54f907 100644
--- a/x11-misc/treeline/Manifest
+++ b/x11-misc/treeline/Manifest
@@ -1,3 +1,4 @@
DIST treeline-1.4.1.tar.gz 499500 SHA256 d66e0fcae9bcb5e54f664381f6af73f360f9ff46c91787a126c7197fbe685489 SHA512 85e87d4201eca19fb4255eacef89b7975f982a32790e74b5a35ab37e42e316eb45a1518f093097141dc5db1a8a090537f42e35fddf3f51b3ae4cf4c812f9ea95 WHIRLPOOL 7f97e943d86f6f94fd32dbb2836ed9a5f1cd38c777322962b7809705f48886ad4988c3739907020976ee0aa798d5b9b76302d05fb753f642fa839cd556175312
-DIST treeline-1.9.4.tar.gz 327826 SHA256 eb26c836024687c2cbe386c129d49b72891333d6908ba6b7109aa1bad58a2f62 SHA512 be9a2dd385a941794adb779a3f4deec4d855ec2dbcfb92ed421879c212ab78dcc401dc0ee7fbdbd075faa60f3d290219877bcf97376e9df4d00d1cd9c2774f2d WHIRLPOOL 97682512a2f1461cee4230a2adeba47284a50263c3a2dbad2588bb503abbfc3ccb118f7832b7dd6b92946881ca79fc6a042f0d50d2d0c21f5549ca9c83773f5e
+DIST treeline-2.0.2.tar.gz 451377 SHA256 80379b6ebb5b825a02f4b8d0bb65d78f9895db5e25065f85353833e9d8ebd4c8 SHA512 05d8464ce460e1b50a5d64fb23f4c7980ef419833272bc8f2a87303b1f3cc7a363f138476a23b0d178c76f7ad654136c007f8e81a132c2b182bdcedba28be164 WHIRLPOOL 866c361f692c3f34e6d87c053d62a8800aa2fdb7b1ca1b4c63bc3e8c4a62479569e2a4c883360898bac62b7af3e9784ee1a76dee832e9754c18972bfcdd16b0c
+DIST treeline-2.1.1.tar.gz 457877 SHA256 fbfed5a8244ea8a2705d846d1d4c0004d07a67780203219df1e736cdd5b914f7 SHA512 d92a8ad06ae368799435372ec3ce49946ca4d0b0cd365d286d3045d60b18d74789bad8f0f32ea1ac11497304076db288f29838c467c84a4bc6c2d8230f627565 WHIRLPOOL 0f7736172b50a3f1f7a66e69d33c1e7db734070ebc92b8d8e4111f0c4563e6bba38d6ea35823dfa3c142f759344f5e4187235fb326b0ea434be24d0f16aaa9bf
DIST treeline-i18n-1.4.1a.tar.gz 279797 SHA256 891f086b0718336911ef118a4e25772c639cb48c1bea007031b5da075512e478 SHA512 82a79d24d451f5512c80b7647a6d10146649d2224c5ced8e5b402b44dea5d3d7cb00a3e8c96384d499fe2eb87dca686feb74a79db083e531fdb872218f54861b WHIRLPOOL cd8cac4419273369800314b7428e202586540e5b348203ab6567c73d1861e48b1f83e4f7c5c21da6fce9800d95bca71a5b057a81f2e22e64a2a656cd54d32dda
diff --git a/x11-misc/treeline/treeline-2.0.2.ebuild b/x11-misc/treeline/treeline-2.0.2.ebuild
new file mode 100644
index 000000000000..fe4447e017f1
--- /dev/null
+++ b/x11-misc/treeline/treeline-2.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_4 )
+PYTHON_REQ_USE="xml"
+
+inherit eutils python-single-r1
+
+DESCRIPTION="TreeLine is a structured information storage program"
+HOMEPAGE="http://treeline.bellz.org/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/TreeLine"
+
+src_prepare() {
+ rm doc/LICENSE || die
+
+ python_export PYTHON_SITEDIR
+ sed -i "s;prefixDir, 'lib;'${PYTHON_SITEDIR};" install.py || die
+}
+
+src_install() {
+ "${EPYTHON}" install.py -x -p /usr/ -d /usr/share/doc/${PF} -b "${D}" || die
+}
diff --git a/x11-misc/treeline/treeline-1.9.4.ebuild b/x11-misc/treeline/treeline-2.1.1.ebuild
index f93d114afa86..6329f671d1fc 100644
--- a/x11-misc/treeline/treeline-1.9.4.ebuild
+++ b/x11-misc/treeline/treeline-2.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5