summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-23 18:41:03 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-25 15:14:59 +0100
commit3a9f15ec11b8d2c74bd22ba11ae4db8b623df90a (patch)
treea36d86e6782dc87e19a0fede18e220a6bbaff072 /x11-misc/unclutter/unclutter-8-r4.ebuild
parentx11-misc/xtitle: Remove old (diff)
downloadgentoo-3a9f15ec11b8d2c74bd22ba11ae4db8b623df90a.tar.gz
gentoo-3a9f15ec11b8d2c74bd22ba11ae4db8b623df90a.tar.bz2
gentoo-3a9f15ec11b8d2c74bd22ba11ae4db8b623df90a.zip
x11-misc/unclutter: EAPI bump 5 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4071
Diffstat (limited to 'x11-misc/unclutter/unclutter-8-r4.ebuild')
-rw-r--r--x11-misc/unclutter/unclutter-8-r4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/unclutter/unclutter-8-r4.ebuild b/x11-misc/unclutter/unclutter-8-r4.ebuild
new file mode 100644
index 000000000000..1372a6c79a66
--- /dev/null
+++ b/x11-misc/unclutter/unclutter-8-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hides mouse pointer while not in use"
+HOMEPAGE="http://www.ibiblio.org/pub/X11/contrib/utilities/unclutter-8.README"
+SRC_URI="ftp://ftp.x.org/contrib/utilities/${P}.tar.Z"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-FocusOut.patch
+)
+
+src_compile() {
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" LDOPTIONS="${LDFLAGS}"
+}
+
+src_install () {
+ dobin unclutter
+ newman unclutter.man unclutter.1x
+ einstalldocs
+}