summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/urxvt-font-size
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/urxvt-font-size')
-rw-r--r--x11-misc/urxvt-font-size/Manifest1
-rw-r--r--x11-misc/urxvt-font-size/metadata.xml11
-rw-r--r--x11-misc/urxvt-font-size/urxvt-font-size-1.1.ebuild31
-rw-r--r--x11-misc/urxvt-font-size/urxvt-font-size-9999.ebuild31
4 files changed, 74 insertions, 0 deletions
diff --git a/x11-misc/urxvt-font-size/Manifest b/x11-misc/urxvt-font-size/Manifest
new file mode 100644
index 000000000000..d37f6fc84918
--- /dev/null
+++ b/x11-misc/urxvt-font-size/Manifest
@@ -0,0 +1 @@
+DIST urxvt-font-size-1.1.tar.gz 5490 SHA256 f3a4b917680f028b960741a95e6fafba4574c80c089b1e36faf5528ba1b4d54d SHA512 923cf79dc11cdfd53bf7f0a5bc909cc80916f9e956f1aadc2cfa609d1c9c33211c0b023f5dca4c56a12acf7d3c70d7229e5a78783d20965964511b5f6ad01b1d WHIRLPOOL a4c5a860fe12666f91c3136d25bce110dda85879e8512d3f70ef55570d33718b7fb27ffb313e852ef18df743347d4a0ab2536d03d95bd0c46e75895b8c8f5d43
diff --git a/x11-misc/urxvt-font-size/metadata.xml b/x11-misc/urxvt-font-size/metadata.xml
new file mode 100644
index 000000000000..9d0a9a7512a3
--- /dev/null
+++ b/x11-misc/urxvt-font-size/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">majutsushi/urxvt-font-size</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/urxvt-font-size/urxvt-font-size-1.1.ebuild b/x11-misc/urxvt-font-size/urxvt-font-size-1.1.ebuild
new file mode 100644
index 000000000000..20cf2b574ffd
--- /dev/null
+++ b/x11-misc/urxvt-font-size/urxvt-font-size-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://github.com/majutsushi/urxvt-font-size.git"
+ inherit git-r3
+else
+ KEYWORDS="amd64 x86"
+ SRC_URI="https://github.com/majutsushi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Perl extension for rxvt-unicode to change the font size on the fly"
+HOMEPAGE="https://github.com/majutsushi/urxvt-font-size/"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ x11-apps/xlsfonts
+ x11-terms/rxvt-unicode[perl]
+"
+
+src_install() {
+ insinto /usr/$(get_libdir)/urxvt/perl
+ doins font-size
+ dodoc README.markdown
+}
diff --git a/x11-misc/urxvt-font-size/urxvt-font-size-9999.ebuild b/x11-misc/urxvt-font-size/urxvt-font-size-9999.ebuild
new file mode 100644
index 000000000000..3cccaa79a6be
--- /dev/null
+++ b/x11-misc/urxvt-font-size/urxvt-font-size-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://github.com/majutsushi/urxvt-font-size.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/majutsushi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Perl extension for rxvt-unicode to change the font size on the fly"
+HOMEPAGE="https://github.com/majutsushi/urxvt-font-size/"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ x11-apps/xlsfonts
+ x11-terms/rxvt-unicode[perl]
+"
+
+src_install() {
+ insinto /usr/$(get_libdir)/urxvt/perl
+ doins font-size
+ dodoc README.markdown
+}