summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Chernov <4ernov@gmail.com>2019-09-16 00:05:16 +0300
committerBenda Xu <heroxbd@gentoo.org>2020-02-14 15:52:56 +0800
commit3a912eb430ddaddc743756948975f6de3ee4f129 (patch)
tree51caf8910ae9510784d83ae85d63052d328406a7 /x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild
parentsys-devel/bison: Removed old (diff)
downloadgentoo-3a912eb430ddaddc743756948975f6de3ee4f129.tar.gz
gentoo-3a912eb430ddaddc743756948975f6de3ee4f129.tar.bz2
gentoo-3a912eb430ddaddc743756948975f6de3ee4f129.zip
x11-misc/xbindkeys: Add release event status mask patch.
Add and make apply a patch to x11-misc/xbindkeys, which applies mask to release event status fixing layout issues. The patch is actually merged to xbindkeys upstream, but no new version is released since then. Closes: https://bugs.gentoo.org/548000. Closes: https://github.com/gentoo/gentoo/pull/12938 Reference: https://askubuntu.com/a/825622 Reference: https://lists.nongnu.org/archive/html/xbindkeys-devel/2014-02/msg00002.html Signed-off-by: Alexey Chernov <4ernov@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild')
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild
new file mode 100644
index 000000000000..14de366f5dcc
--- /dev/null
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Tool for launching commands on keystrokes"
+SRC_URI="http://www.nongnu.org/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.nongnu.org/xbindkeys/xbindkeys.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="guile tk"
+
+RDEPEND="x11-libs/libX11
+ guile? ( >=dev-scheme/guile-1.8.4[deprecated] )
+ tk? ( dev-lang/tk )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-apply-mask-on-release-event-status.patch"
+)
+
+src_configure() {
+ econf \
+ $(use_enable tk) \
+ $(use_enable guile)
+}