summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xfe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xfe')
-rw-r--r--x11-misc/xfe/Manifest1
-rw-r--r--x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch33
-rw-r--r--x11-misc/xfe/metadata.xml8
-rw-r--r--x11-misc/xfe/xfe-1.40.ebuild73
4 files changed, 115 insertions, 0 deletions
diff --git a/x11-misc/xfe/Manifest b/x11-misc/xfe/Manifest
new file mode 100644
index 000000000000..014e05c1fdd3
--- /dev/null
+++ b/x11-misc/xfe/Manifest
@@ -0,0 +1 @@
+DIST xfe-1.40.tar.gz 2574477 SHA256 2b476f15beff1a1ce85dd4ce6559bb7ceca78b866c63fb4986456862a36862a8 SHA512 22cf9fd60dcd4b594d7ff39ea78d10a8c71ee2433025acf32b7e69457a5e86852b54e448ebc1e3f63f39bf720767064c74c46eaf2b999c14ae76417d33272892 WHIRLPOOL 5c3ce54db8ac3c7e99f590100a493e3611ea2cad90b498d0b673d1366a85ed0280c8aa664f60f9de633192964a5cead4efee65e6eee69f65fdd0928061e07e0e
diff --git a/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch b/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch
new file mode 100644
index 000000000000..eb08d0ca069f
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch
@@ -0,0 +1,33 @@
+--- a/src/ViewWindow.cpp
++++ a/src/ViewWindow.cpp
+@@ -12,6 +12,8 @@
+ #include <string.h>
+ #include <unistd.h>
+
++#include <X11/Xlib.h>
++
+ #include <fx.h>
+ #include <fxkeys.h>
+ #include <FXPNGIcon.h>
+--- a/src/WriteWindow.cpp
++++ a/src/WriteWindow.cpp
+@@ -12,6 +12,8 @@
+ #include <unistd.h>
+ #include <signal.h>
+
++#include <X11/Xlib.h>
++
+ #include <fx.h>
+ #include <fxkeys.h>
+ #include <FXPNGIcon.h>
+--- a/src/XFileExplorer.cpp
++++ a/src/XFileExplorer.cpp
+@@ -8,6 +8,8 @@
+ #include <sys/wait.h>
+ #include <unistd.h>
+
++#include <X11/Xlib.h>
++
+ #include <fx.h>
+ #include <fxkeys.h>
+ #include <FXPNGIcon.h>
diff --git a/x11-misc/xfe/metadata.xml b/x11-misc/xfe/metadata.xml
new file mode 100644
index 000000000000..900869d128f4
--- /dev/null
+++ b/x11-misc/xfe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">xfe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xfe/xfe-1.40.ebuild b/x11-misc/xfe/xfe-1.40.ebuild
new file mode 100644
index 000000000000..ce72a0b34a3a
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.40.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="
+ bs ca cs da de el es_AR es_CO es fr hu it ja nl no pl pt_BR pt_PT ru sv tr
+ zh_CN zh_TW
+"
+inherit autotools l10n
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/fox:1.6[truetype,png]
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+src_prepare() {
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s:\s\s*:\n:g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ l10n_for_each_disabled_locale_do rm_locale
+
+ sed -i \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ --enable-minimalflags
+}