summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xidle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xidle')
-rw-r--r--x11-misc/xidle/Manifest1
-rw-r--r--x11-misc/xidle/files/xidle-24102005-dead.patch15
-rw-r--r--x11-misc/xidle/metadata.xml8
-rw-r--r--x11-misc/xidle/xidle-24102005.ebuild37
4 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/xidle/Manifest b/x11-misc/xidle/Manifest
new file mode 100644
index 000000000000..220b79759628
--- /dev/null
+++ b/x11-misc/xidle/Manifest
@@ -0,0 +1 @@
+DIST xidle-24102005.tar.bz2 4886 RMD160 1f1b096ddc24a1f0587d644277e3e924e43a84be SHA1 bc62c95742549880dbd75a49e87e1dc7175473fb SHA256 c5b003bc552fd51595a522e09da15335f2d7cb21882d62cbea7d5f0df73d08f9
diff --git a/x11-misc/xidle/files/xidle-24102005-dead.patch b/x11-misc/xidle/files/xidle-24102005-dead.patch
new file mode 100644
index 000000000000..26ce27bcc0bd
--- /dev/null
+++ b/x11-misc/xidle/files/xidle-24102005-dead.patch
@@ -0,0 +1,15 @@
+--- a/xidle.c
++++ b/xidle.c
+@@ -87,10 +87,10 @@
+ void close_x(struct xinfo *);
+ void init_x(const char *, struct xinfo *, int, int);
+ void handler(int);
+-__dead void usage(void);
++void usage(void);
+
+
+-__dead void
++void
+ usage()
+ {
+ fprintf(stderr, "Usage:\n%s %s\n", __progname,
diff --git a/x11-misc/xidle/metadata.xml b/x11-misc/xidle/metadata.xml
new file mode 100644
index 000000000000..c3a21340a392
--- /dev/null
+++ b/x11-misc/xidle/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-misc/xidle/xidle-24102005.ebuild b/x11-misc/xidle/xidle-24102005.ebuild
new file mode 100644
index 000000000000..7e286b09a122
--- /dev/null
+++ b/x11-misc/xidle/xidle-24102005.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="xidle monitors inactivity in X and runs the specified program when
+a timeout occurs."
+HOMEPAGE="http://www.freebsdsoftware.org/x11/xidle.html"
+SRC_URI="mirror://freebsd/ports/local-distfiles/novel/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-dead.patch"
+}
+
+src_compile() {
+ local my_compile="$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN}{,.c} -lXss -lX11"
+ echo ${my_compile}
+ eval ${my_compile} || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}