summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-16 16:31:52 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-17 21:14:48 +0100
commitb1a08169cbadc00a20055e8a6b3af122d17a362f (patch)
tree82ba07a14cb52dd56e9ddab4f59b124eb2eb1552 /x11-misc/xkbd
parentx11-misc/devilspie: Bump to 0.23 (diff)
downloadgentoo-b1a08169cbadc00a20055e8a6b3af122d17a362f.tar.gz
gentoo-b1a08169cbadc00a20055e8a6b3af122d17a362f.tar.bz2
gentoo-b1a08169cbadc00a20055e8a6b3af122d17a362f.zip
x11-misc/xkbd: EAPI bump 4 -> 6, remove broken doc USE
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3987
Diffstat (limited to 'x11-misc/xkbd')
-rw-r--r--x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch4
-rw-r--r--x11-misc/xkbd/files/xkbd-0.8.16-desktop.patch19
-rw-r--r--x11-misc/xkbd/xkbd-0.8.16-r1.ebuild39
-rw-r--r--x11-misc/xkbd/xkbd-0.8.16.ebuild56
4 files changed, 60 insertions, 58 deletions
diff --git a/x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch b/x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch
index 0d4d5c29cc9c..ff30537add44 100644
--- a/x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch
+++ b/x11-misc/xkbd/files/xkbd-0.8.15-fix-keysyms-search.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/287075
---- src/libvirtkeys.c
-+++ src/libvirtkeys.c
+--- a/src/libvirtkeys.c
++++ b/src/libvirtkeys.c
@@ -341,7 +341,7 @@
for (keycode = 0; ((keycode < (maxKeycode - minKeycode + 1)) && !found); keycode++)
diff --git a/x11-misc/xkbd/files/xkbd-0.8.16-desktop.patch b/x11-misc/xkbd/files/xkbd-0.8.16-desktop.patch
new file mode 100644
index 000000000000..987270d1d398
--- /dev/null
+++ b/x11-misc/xkbd/files/xkbd-0.8.16-desktop.patch
@@ -0,0 +1,19 @@
+Fixes following QA issues:
+ * QA Notice: This package installs one or more .desktop files that do not
+ * pass validation.
+ *
+ * /usr/share/applications/inputmethods/xkbd.desktop: error: (will be fatal in the future): value "xkbd.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
+ * /usr/share/applications/inputmethods/xkbd.desktop: error: value "Panel;Utility;MB" for key "Categories" in group "Desktop Entry" contains an unregistered value "MB"; values extending the format should start with "X-"
+ * /usr/share/applications/inputmethods/xkbd.desktop: error: value "Panel;Utility;MB" for key "Categories" in group "Desktop Entry" contains an unregistered value "Panel"; values extending the format should start with "X-"
+ *
+--- a/xkbd.desktop 2003-09-29 20:29:35.000000000 +0300
++++ b/xkbd.desktop 2017-02-16 16:23:40.927035269 +0200
+@@ -3,6 +3,6 @@
+ Comment=Virtual Keyboard
+ Exec=xkbd
+ Type=Application
+-Icon=xkbd.png
+-Categories=Panel;Utility;MB
++Icon=xkbd
++Categories=Utility;Accessibility
+ X-MB-INPUT-MECHANSIM=True
diff --git a/x11-misc/xkbd/xkbd-0.8.16-r1.ebuild b/x11-misc/xkbd/xkbd-0.8.16-r1.ebuild
new file mode 100644
index 000000000000..5c8bedd045a6
--- /dev/null
+++ b/x11-misc/xkbd/xkbd-0.8.16-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="onscreen soft keyboard for X11"
+HOMEPAGE="http://trac.hackable1.org/trac/wiki/Xkbd"
+SRC_URI="http://trac.hackable1.org/trac/raw-attachment/wiki/Xkbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXtst
+ x11-libs/libXpm
+ media-libs/freetype
+ dev-libs/expat
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+DOCS=( AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-geometry.patch
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${PN}-0.8.15-increase-delay.patch
+ "${FILESDIR}"/${PN}-0.8.15-fix-keysyms-search.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
diff --git a/x11-misc/xkbd/xkbd-0.8.16.ebuild b/x11-misc/xkbd/xkbd-0.8.16.ebuild
deleted file mode 100644
index ad0a25f89a43..000000000000
--- a/x11-misc/xkbd/xkbd-0.8.16.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="onscreen soft keyboard for X11"
-HOMEPAGE="http://trac.hackable1.org/trac/wiki/Xkbd"
-SRC_URI="http://trac.hackable1.org/trac/raw-attachment/wiki/Xkbd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="doc debug"
-
-RDEPEND="x11-libs/libXrender
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXtst
- x11-libs/libXpm
- media-libs/freetype
- dev-libs/expat
- sys-libs/zlib
- doc? ( app-text/docbook-sgml-utils )"
-DEPEND="${RDEPEND}
- x11-proto/xproto
- x11-proto/xextproto"
-
-src_prepare() {
- # 2008-03-23 gi1242: Fix handling of -geometry argument
- epatch "${FILESDIR}"/${P}-fix-geometry.patch
- # 2008-03-23 gi1242: Increase default repeat delay
- epatch "${FILESDIR}"/${PN}-0.8.15-increase-delay.patch
- epatch "${FILESDIR}"/${PN}-0.8.15-fix-keysyms-search.patch
-}
-
-src_configure() {
- econf \
- $(use_enable debug)
-}
-
-src_compile() {
- default
-
- use doc && docbook2html README
-}
-
-src_install() {
- default
-
- if use doc; then
- insinto /usr/share/doc/${PF}/html
- doins *.html
- fi
-}