summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-06-06 16:04:44 -0700
committerMatt Turner <mattst88@gentoo.org>2018-06-06 16:05:46 -0700
commit7f7f48e721e53013bf16caf7aefd8113f9e6b2d3 (patch)
tree410209640c9a5127073f7bc8cbc7d0d20691386d /x11-misc/xkeyboard-config
parentgames-strategy/ufoai: Fetch the git snapshot from my devspace (diff)
downloadgentoo-7f7f48e721e53013bf16caf7aefd8113f9e6b2d3.tar.gz
gentoo-7f7f48e721e53013bf16caf7aefd8113f9e6b2d3.tar.bz2
gentoo-7f7f48e721e53013bf16caf7aefd8113f9e6b2d3.zip
x11-misc/xkeyboard-config: Version bump 2.24
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.24.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 27b60247873d..a5443e9436cc 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1 +1,2 @@
DIST xkeyboard-config-2.23.1.tar.bz2 1053991 BLAKE2B c5551eb39f4cb240d36943d1e2fd3f9156bada61bb33013f6c43d036fb55aef5332fdb133ab6cfb03ebdbc68dcb3df7d974e3972904936b1e6dd89eafc4ec647 SHA512 d651bb89c265e58abe8bba4af6683364a8023cb73af7d00f401f33960e44fa94a7d8a8fdd2483d6703d1c261ca72ae5f2b53f543cfb70b2f571cfe9dcb80c3ba
+DIST xkeyboard-config-2.24.tar.bz2 1057889 BLAKE2B be9c6e0e0885c8a40406b3cf761f854268026084f2025a1a9f3e0326570543dd7fa11a2355947da1018d35af2ab4818092abbef5b7bdc3da923fcfe65059977d SHA512 96b65d18a85443a9bf93d65a4423da6e2b3d44882dae6a03bf46768a92017e9762cf3721361ba399c2873d53782944d0292eb673484f1cd8a8bdbf643e7a1dc0
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.24.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.24.ebuild
new file mode 100644
index 000000000000..40b72722a506
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.24.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/xkeyboard-config.git"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="https://www.x.org/releases/individual/data/xkeyboard-config/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="!<x11-apps/xkbcomp-1.2.3
+ !<x11-libs/libX11-1.4.3"
+DEPEND="
+ sys-devel/gettext
+ dev-util/intltool"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}