summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-04-22 16:23:38 +0200
committerSebastian Pipping <sping@gentoo.org>2017-04-22 16:30:15 +0200
commit237ca8a7efd86c936734288889b414272cda1968 (patch)
tree3b85432a0473d16c4536573b34141e2a4923c4f5 /x11-misc/xprintidle/xprintidle-2.0.ebuild
parentsys-cluster/libqb: ebuild cleanup and eapi bump (diff)
downloadgentoo-237ca8a7efd86c936734288889b414272cda1968.tar.gz
gentoo-237ca8a7efd86c936734288889b414272cda1968.tar.bz2
gentoo-237ca8a7efd86c936734288889b414272cda1968.zip
x11-misc/xprintidle: 2.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'x11-misc/xprintidle/xprintidle-2.0.ebuild')
-rw-r--r--x11-misc/xprintidle/xprintidle-2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/xprintidle/xprintidle-2.0.ebuild b/x11-misc/xprintidle/xprintidle-2.0.ebuild
new file mode 100644
index 000000000000..83b621d16fed
--- /dev/null
+++ b/x11-misc/xprintidle/xprintidle-2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Prints user's X server idle time in milliseconds"
+HOMEPAGE="https://github.com/lucianposton/xprintidle"
+SRC_URI="https://github.com/lucianposton/xprintidle/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ "
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ AUTHORS
+ ChangeLog
+ NEWS
+ README
+)
+
+src_prepare() {
+ eapply_user
+
+ # Address "configure: WARNING: 'missing' script is too old or missing"
+ eautoreconf
+}