summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xscreensaver/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xscreensaver/files')
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.05-interix.patch32
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.20-blurb-hndl-test-passwd.patch12
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.20-test-passwd-segv-tty.patch13
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch23
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.21-gentoo.patch106
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.28-comment-style.patch21
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.31-pragma.patch11
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.33-gentoo.patch106
8 files changed, 324 insertions, 0 deletions
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.05-interix.patch b/x11-misc/xscreensaver/files/xscreensaver-5.05-interix.patch
new file mode 100644
index 000000000000..2a5eead4879f
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.05-interix.patch
@@ -0,0 +1,32 @@
+diff -ru xscreensaver-5.05.orig/driver/prefs.c xscreensaver-5.05/driver/prefs.c
+--- xscreensaver-5.05.orig/driver/prefs.c 2006-05-24 00:03:47 +0200
++++ xscreensaver-5.05/driver/prefs.c 2008-03-11 09:20:58 +0100
+@@ -951,9 +951,12 @@
+ {
+ p->init_file_date = write_date;
+
++/* Interix has no sync() or alike. */
++#ifndef __INTERIX
+ /* Since the .xscreensaver file is used for IPC, let's try and make
+ sure that the bits actually land on the disk right away. */
+ sync ();
++#endif
+
+ status = 0; /* wrote and renamed successfully! */
+ }
+diff -ru xscreensaver-5.05.orig/driver/setuid.c xscreensaver-5.05/driver/setuid.c
+--- xscreensaver-5.05.orig/driver/setuid.c 2006-02-09 03:33:29 +0100
++++ xscreensaver-5.05/driver/setuid.c 2008-03-11 09:22:59 +0100
+@@ -136,9 +136,12 @@
+ if (uid == (uid_t) -1) uid = (uid_t) -2;
+
+ errno = 0;
++
++#ifndef __INTERIX
+ if (setgroups_needed_p (gid) &&
+ setgroups (1, &gid) < 0)
+ sgs_errno = errno ? errno : -1;
++#endif
+
+ errno = 0;
+ if (setgid (gid) != 0)
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.20-blurb-hndl-test-passwd.patch b/x11-misc/xscreensaver/files/xscreensaver-5.20-blurb-hndl-test-passwd.patch
new file mode 100644
index 000000000000..bfd48d1cc96e
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.20-blurb-hndl-test-passwd.patch
@@ -0,0 +1,12 @@
+http://pkgs.fedoraproject.org/cgit/xscreensaver.git/tree/xscreensaver-5.17-blurb-hndl-test-passwd.patch
+
+--- driver/test-passwd.c
++++ driver/test-passwd.c
+@@ -66,6 +66,7 @@
+ Bool update_screen_layout (saver_info *si) { return 0; }
+
+ const char *blurb(void) { return progname; }
++Bool in_signal_handler_p = 0;
+ Atom XA_SCREENSAVER, XA_DEMO, XA_PREFS;
+
+ void
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.20-test-passwd-segv-tty.patch b/x11-misc/xscreensaver/files/xscreensaver-5.20-test-passwd-segv-tty.patch
new file mode 100644
index 000000000000..ab5deebc424a
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.20-test-passwd-segv-tty.patch
@@ -0,0 +1,13 @@
+http://pkgs.fedoraproject.org/cgit/xscreensaver.git/tree/xscreensaver-5.12-test-passwd-segv-tty.patch
+
+--- driver/passwd.c
++++ driver/passwd.c
+@@ -205,7 +205,7 @@
+ {
+ # ifdef HAVE_SYSLOG
+ struct passwd *pw = getpwuid (getuid ());
+- char *d = DisplayString (si->dpy);
++ char *d = (si->dpy ? DisplayString (si->dpy) : 0);
+ char *u = (pw && pw->pw_name ? pw->pw_name : "???");
+ int opt = 0;
+ int fac = 0;
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch b/x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch
new file mode 100644
index 000000000000..995b4ea89608
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch
@@ -0,0 +1,23 @@
+http://pkgs.fedoraproject.org/cgit/xscreensaver.git/tree/xscreensaver-5.12-tests-miscfix.patch
+
+--- driver/test-xdpms.c
++++ driver/test-xdpms.c
+@@ -29,7 +29,6 @@
+
+ #include <X11/Xproto.h>
+ #include <X11/extensions/dpms.h>
+-#include <X11/extensions/dpmsstr.h>
+
+ extern Bool DPMSQueryExtension (Display *dpy, int *event_ret, int *error_ret);
+ extern Bool DPMSCapable (Display *dpy);
+--- driver/Makefile.in
++++ driver/Makefile.in
+@@ -850,7 +850,7 @@
+ test-mlstring: test-mlstring.o
+ $(CC) -DTEST $(LDFLAGS) -o $@ test-mlstring.o $(SAVER_LIBS)
+
+-TEST_FADE_OBJS = test-fade.o $(UTILS_SRC)/fade.o $(DEMO_UTIL_OBJS)
++TEST_FADE_OBJS = test-fade.o $(UTILS_BIN)/fade.o $(DEMO_UTIL_OBJS)
+ test-fade: test-fade.o $(UTILS_BIN)/fade.o
+ $(CC) $(LDFLAGS) -o $@ $(TEST_FADE_OBJS) $(SAVER_LIBS)
+
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.21-gentoo.patch b/x11-misc/xscreensaver/files/xscreensaver-5.21-gentoo.patch
new file mode 100644
index 000000000000..b69e19783200
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.21-gentoo.patch
@@ -0,0 +1,106 @@
+--- xscreensaver-5.21/driver/XScreenSaver.ad.in
++++ xscreensaver-5.21/driver/XScreenSaver.ad.in
+@@ -31,21 +31,21 @@
+ *mode: random
+ *timeout: 0:10:00
+ *cycle: 0:10:00
+-*lockTimeout: 0:00:00
++*lockTimeout: 0:30:00
+ *passwdTimeout: 0:00:30
+-*dpmsEnabled: False
++*dpmsEnabled: True
+ *dpmsQuickoffEnabled: False
+ *dpmsStandby: 2:00:00
+ *dpmsSuspend: 2:00:00
+ *dpmsOff: 4:00:00
+-*grabDesktopImages: True
++*grabDesktopImages: False
+ *grabVideoFrames: False
+ *chooseRandomImages: @DEFAULT_IMAGES_P@
+ ! This can be a local directory name, or the URL of an RSS or Atom feed.
+ *imageDirectory: @DEFAULT_IMAGE_DIRECTORY@
+ *nice: 10
+ *memoryLimit: 0
+-*lock: False
++*lock: True
+ *verbose: False
+ *timestamp: True
+ *fade: True
+@@ -62,7 +62,7 @@
+ *textLiteral: XScreenSaver
+ *textFile: @DEFAULT_TEXT_FILE@
+ *textProgram: fortune
+-*textURL: http://en.wikipedia.org/w/index.php?title=Special:NewPages&feed=rss
++*textURL: http://planet.gentoo.org/rss20.xml
+
+ *overlayTextForeground: #FFFF00
+ *overlayTextBackground: #000000
+@@ -122,7 +122,8 @@
+
+ ! The format used for printing the date and time in the password dialog box
+ ! (see the strftime(3) manual page for details.)
+-*dateFormat: %d-%b-%y (%a); %I:%M %p
++!*dateFormat: %d-%b-%y (%a); %I:%M %p
++*dateFormat: %x %X
+ ! To show the time only:
+ ! *dateFormat: %I:%M %p
+ ! For 24 hour time:
+--- xscreensaver-5.21/hacks/barcode.c
++++ xscreensaver-5.21/hacks/barcode.c
+@@ -131,7 +131,6 @@
+ "children",
+ "chocolate",
+ "CLONE",
+- "cock",
+ "constriction",
+ "contrition",
+ "cop",
+@@ -265,7 +264,6 @@
+ "punishment",
+ "punk rock",
+ "punk",
+- "pussy",
+ "quagmire",
+ "quarantine",
+ "quartz",
+@@ -333,8 +331,6 @@
+ "vegetarian",
+ "venom",
+ "verifiability",
+- "viagra",
+- "vibrator",
+ "victim",
+ "vignette",
+ "villainy",
+--- xscreensaver-5.21/hacks/glx/glsnake.c
++++ xscreensaver-5.21/hacks/glx/glsnake.c
+@@ -565,17 +565,17 @@
+ ZERO, PIN, ZERO, ZERO, ZERO, ZERO, PIN, ZERO, ZERO, ZERO, ZERO,
+ ZERO, PIN, ZERO }
+ },
+- { "erect penis", /* thanks benno */
++ { "shuffle board", /* thanks benno */
+ { PIN, ZERO, PIN, PIN, ZERO, ZERO, PIN, ZERO, ZERO, ZERO, PIN,
+ PIN, ZERO, ZERO, ZERO, RIGHT, ZERO, ZERO, ZERO, ZERO, ZERO, ZERO,
+ ZERO, ZERO }
+ },
+- { "flaccid penis",
++ { "flaccid anchor",
+ { PIN, ZERO, PIN, PIN, ZERO, ZERO, PIN, ZERO, ZERO, ZERO, PIN,
+ PIN, ZERO, ZERO, ZERO, RIGHT, PIN, ZERO, ZERO, ZERO, ZERO, ZERO,
+ ZERO, ZERO }
+ },
+- { "vagina",
++ { "engagement ring",
+ { RIGHT, ZERO, ZERO, ZERO, RIGHT, ZERO, ZERO, PIN, ZERO, ZERO,
+ LEFT, ZERO, ZERO, ZERO, LEFT, ZERO, LEFT, PIN, LEFT, PIN, RIGHT,
+ PIN, RIGHT, ZERO }
+@@ -995,7 +995,7 @@
+ { "Parrot",
+ { ZERO, ZERO, ZERO, ZERO, RIGHT, RIGHT, ZERO, LEFT, PIN, RIGHT, ZERO, RIGHT, ZERO, RIGHT, ZERO, RIGHT, PIN, LEFT, ZERO, RIGHT, LEFT, ZERO, PIN, ZERO }
+ },
+- { "Penis",
++ { "Shuttle",
+ { PIN, PIN, RIGHT, ZERO, PIN, PIN, ZERO, PIN, ZERO, ZERO, RIGHT, PIN, LEFT, ZERO, ZERO, PIN, ZERO, PIN, PIN, ZERO, LEFT, PIN, PIN, ZERO }
+ },
+ { "PictureComingSoon",
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.28-comment-style.patch b/x11-misc/xscreensaver/files/xscreensaver-5.28-comment-style.patch
new file mode 100644
index 000000000000..6c3143d758b7
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.28-comment-style.patch
@@ -0,0 +1,21 @@
+--- a/hacks/tessellimage.c
++++ b/hacks/tessellimage.c
+@@ -507,15 +507,15 @@
+ out[i].p = (n > 0
+ ? (XPoint *) calloc (out[i].npoints + 1, sizeof (*out[i].p))
+ : 0);
+-//printf("%d: ", i);
++/*printf("%d: ", i);*/
+ for (j = 0; j < out[i].npoints; j++)
+ {
+ ITRIANGLE *tt = &v[t->tri[j]];
+ out[i].p[j].x = (p[tt->p1].x + p[tt->p2].x + p[tt->p3].x) / 3;
+ out[i].p[j].y = (p[tt->p1].y + p[tt->p2].y + p[tt->p3].y) / 3;
+-//printf(" [%d: %d %d]", j, out[i].p[j].x, out[i].p[j].y);
++/*printf(" [%d: %d %d]", j, out[i].p[j].x, out[i].p[j].y);*/
+ }
+-//printf("\n");
++/*printf("\n");*/
+ }
+
+ free (vert_to_tri);
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.31-pragma.patch b/x11-misc/xscreensaver/files/xscreensaver-5.31-pragma.patch
new file mode 100644
index 000000000000..97f4656344cb
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.31-pragma.patch
@@ -0,0 +1,11 @@
+--- a/hacks/memscroller.c
++++ b/hacks/memscroller.c
+@@ -307,7 +307,7 @@
+ -- sbrk(2) man page on BSD systems, as of 1995 or so.
+ */
+ #ifdef HAVE_SBRK
+-# if (__GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 2)) /* gcc >= 4.2 */
++# if (__GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 6)) /* gcc >= 4.6 */
+ /* Don't print "warning: 'sbrk' is deprecated". */
+ # pragma GCC diagnostic ignored "-Wdeprecated-declarations"
+ # endif
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.33-gentoo.patch b/x11-misc/xscreensaver/files/xscreensaver-5.33-gentoo.patch
new file mode 100644
index 000000000000..e199c6def68e
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.33-gentoo.patch
@@ -0,0 +1,106 @@
+--- a/driver/XScreenSaver.ad.in
++++ b/driver/XScreenSaver.ad.in
+@@ -31,21 +31,21 @@
+ *mode: random
+ *timeout: 0:10:00
+ *cycle: 0:10:00
+-*lockTimeout: 0:00:00
++*lockTimeout: 0:30:00
+ *passwdTimeout: 0:00:30
+-*dpmsEnabled: False
++*dpmsEnabled: True
+ *dpmsQuickoffEnabled: False
+ *dpmsStandby: 2:00:00
+ *dpmsSuspend: 2:00:00
+ *dpmsOff: 4:00:00
+-*grabDesktopImages: True
++*grabDesktopImages: False
+ *grabVideoFrames: False
+ *chooseRandomImages: @DEFAULT_IMAGES_P@
+ ! This can be a local directory name, or the URL of an RSS or Atom feed.
+ *imageDirectory: @DEFAULT_IMAGE_DIRECTORY@
+ *nice: 10
+ *memoryLimit: 0
+-*lock: False
++*lock: True
+ *verbose: False
+ *timestamp: True
+ *fade: True
+@@ -63,7 +63,7 @@
+ *textLiteral: XScreenSaver
+ *textFile: @DEFAULT_TEXT_FILE@
+ *textProgram: fortune
+-*textURL: https://en.wikipedia.org/w/index.php?title=Special:NewPages&feed=rss
++*textURL: https://planet.gentoo.org/rss20.xml
+
+ *overlayTextForeground: #FFFF00
+ *overlayTextBackground: #000000
+@@ -123,7 +123,8 @@
+
+ ! The format used for printing the date and time in the password dialog box
+ ! (see the strftime(3) manual page for details.)
+-*dateFormat: %d-%b-%y (%a); %I:%M %p
++!*dateFormat: %d-%b-%y (%a); %I:%M %p
++*dateFormat: %x %X
+ ! To show the time only:
+ ! *dateFormat: %I:%M %p
+ ! For 24 hour time:
+--- a/hacks/barcode.c
++++ a/hacks/barcode.c
+@@ -131,7 +131,6 @@
+ "children",
+ "chocolate",
+ "CLONE",
+- "cock",
+ "constriction",
+ "contrition",
+ "cop",
+@@ -265,7 +264,6 @@
+ "punishment",
+ "punk rock",
+ "punk",
+- "pussy",
+ "quagmire",
+ "quarantine",
+ "quartz",
+@@ -333,8 +331,6 @@
+ "vegetarian",
+ "venom",
+ "verifiability",
+- "viagra",
+- "vibrator",
+ "victim",
+ "vignette",
+ "villainy",
+--- a/hacks/glx/glsnake.c
++++ a/hacks/glx/glsnake.c
+@@ -565,17 +565,17 @@
+ ZERO, PIN, ZERO, ZERO, ZERO, ZERO, PIN, ZERO, ZERO, ZERO, ZERO,
+ ZERO, PIN, ZERO }
+ },
+- { "erect penis", /* thanks benno */
++ { "shuffle board", /* thanks benno */
+ { PIN, ZERO, PIN, PIN, ZERO, ZERO, PIN, ZERO, ZERO, ZERO, PIN,
+ PIN, ZERO, ZERO, ZERO, RIGHT, ZERO, ZERO, ZERO, ZERO, ZERO, ZERO,
+ ZERO, ZERO }
+ },
+- { "flaccid penis",
++ { "flaccid anchor",
+ { PIN, ZERO, PIN, PIN, ZERO, ZERO, PIN, ZERO, ZERO, ZERO, PIN,
+ PIN, ZERO, ZERO, ZERO, RIGHT, PIN, ZERO, ZERO, ZERO, ZERO, ZERO,
+ ZERO, ZERO }
+ },
+- { "vagina",
++ { "engagement ring",
+ { RIGHT, ZERO, ZERO, ZERO, RIGHT, ZERO, ZERO, PIN, ZERO, ZERO,
+ LEFT, ZERO, ZERO, ZERO, LEFT, ZERO, LEFT, PIN, LEFT, PIN, RIGHT,
+ PIN, RIGHT, ZERO }
+@@ -995,7 +995,7 @@
+ { "Parrot",
+ { ZERO, ZERO, ZERO, ZERO, RIGHT, RIGHT, ZERO, LEFT, PIN, RIGHT, ZERO, RIGHT, ZERO, RIGHT, ZERO, RIGHT, PIN, LEFT, ZERO, RIGHT, LEFT, ZERO, PIN, ZERO }
+ },
+- { "Penis",
++ { "Shuttle",
+ { PIN, PIN, RIGHT, ZERO, PIN, PIN, ZERO, PIN, ZERO, ZERO, RIGHT, PIN, LEFT, ZERO, ZERO, PIN, ZERO, PIN, PIN, ZERO, LEFT, PIN, PIN, ZERO }
+ },
+ { "PictureComingSoon",