summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 05:47:58 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:14 -0400
commit6d7ebecbe32b8fd1d3c8fc450aa949431bf77cfd (patch)
tree8f80a7bbb04c6b1000e495e938780988f93b5c16 /x11-misc/xtoolwait
parentx11-misc/xtitle: force gcc -E for imake's generation (diff)
downloadgentoo-6d7ebecbe32b8fd1d3c8fc450aa949431bf77cfd.tar.gz
gentoo-6d7ebecbe32b8fd1d3c8fc450aa949431bf77cfd.tar.bz2
gentoo-6d7ebecbe32b8fd1d3c8fc450aa949431bf77cfd.zip
x11-misc/xtoolwait: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Closes: https://bugs.gentoo.org/870805 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/xtoolwait')
-rw-r--r--x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild b/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
index 379b2beb3faf..f6dfa47f2340 100644
--- a/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
+++ b/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,15 +16,17 @@ KEYWORDS="amd64 ppc x86"
RDEPEND="
x11-libs/libX11
x11-libs/libXext"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="
app-text/rman
- x11-base/xorg-proto
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {