summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-02 21:32:18 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-02 21:32:51 +0100
commit33fc41835807c22f237e21bcac65ff7668fa535c (patch)
tree7236a6a59fa3c045fccf0ceac27068909016657c /x11-misc/xwit/xwit-3.4_p16.ebuild
parentx11-misc/xtrlock: Version 2.12 (diff)
downloadgentoo-33fc41835807c22f237e21bcac65ff7668fa535c.tar.gz
gentoo-33fc41835807c22f237e21bcac65ff7668fa535c.tar.bz2
gentoo-33fc41835807c22f237e21bcac65ff7668fa535c.zip
x11-misc/xwit: Version 3.4_p16
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/xwit/xwit-3.4_p16.ebuild')
-rw-r--r--x11-misc/xwit/xwit-3.4_p16.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/xwit/xwit-3.4_p16.ebuild b/x11-misc/xwit/xwit-3.4_p16.ebuild
new file mode 100644
index 000000000000..cc910e726870
--- /dev/null
+++ b/x11-misc/xwit/xwit-3.4_p16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A collection of simple routines to call some of those X11 functions"
+HOMEPAGE="https://tracker.debian.org/pkg/xwit"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*/}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p/-}.debian.tar.xz
+"
+
+LICENSE="public-domain HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+S=${WORKDIR}/${P/_p*/}.orig
+PATCHES=( "${WORKDIR}"/debian/patches )
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's|gcc|${CC}|g' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin xwit
+ newman xwit.man xwit.1
+ einstalldocs
+}