summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-28 16:45:46 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-28 16:46:49 +0200
commit175f13c1ae51875843a9371e7399a4008a53da06 (patch)
tree6659be0a29118341c127cde6fe7ed3a98c8322e3 /x11-misc/zim
parentnet-misc/networkmanager: security cleanup (diff)
downloadgentoo-175f13c1ae51875843a9371e7399a4008a53da06.tar.gz
gentoo-175f13c1ae51875843a9371e7399a4008a53da06.tar.bz2
gentoo-175f13c1ae51875843a9371e7399a4008a53da06.zip
x11-misc/zim: Version 0.71.0
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Closes: https://bugs.gentoo.org/684588 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/zim')
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.71.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index 2c4a31cc96d3..b745349c61c4 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -2,3 +2,4 @@ DIST zim-0.65.tar.gz 1899614 BLAKE2B e7989d91120f2ffe0668c996b5abd61cc1cb12b2a5a
DIST zim-0.69.tar.gz 2044631 BLAKE2B 447fa4fb2d11b1399668ec6b627e23150577b574afb1e5c33738cb690779f49adb2d60e0b01eb82d2cf0dfd4a430099c1ae4b52186b60a2564c501b93aa01822 SHA512 452b2119d63927765c3807dbbdfadea94be31ee7fd3eb9b8cf79e8699c57478ec9cd392299a6e1dc3690dbe520925cddf5fca4596db809a2cc296bb6669d12af
DIST zim-0.70_rc1.tar.gz 2889546 BLAKE2B ca0c2274472f7e3f50e2b51ba59a75ae1422e7bad86a8fdc55474c150b1ac227ad785c3484d1255079a8aa169bc437e6016254ed8d4691d8e8d78a5112d71038 SHA512 fca61ea5c249ba33187d48a6794c11f30afd664e07462c738ca2b64f7d970e95628ecbcdb9c19a23b70c1609993d4111a9976cdddbf2fd5ad3029014a8a01339
DIST zim-0.70_rc3.tar.gz 2877315 BLAKE2B 1467bbd6bbd11e53120193a5f77dc7ab52eb8f1478c3dbc98e229d784f4432e862ab578277b79058eae43943bfbe8812b45153130779f7c84f14b342d3ba7357 SHA512 32fcad48c2deb9739cb7d3214138cdac7c6499008f884ba61aeb51ec387d600b87c7848abf7982fa165c4130446c307e57ee1762f7107894b70d96ded528bc0e
+DIST zim-0.71.0.tar.gz 2882942 BLAKE2B f1701baf547d43d7a9687e6a1d72313649064f1d3927e14bffd5c8e348fa7a311e307f9b1704c19058bfad07d6715c79399acfdc5701efa9291db3e68065175a SHA512 7c82e19d547795f57c563383aca04a51da02463df71cfe18c4cab0307f46fb425ff0f348b43ae0ab26cb29037bc9d99aed63dbf721a542d071f9674f17f0a64a
diff --git a/x11-misc/zim/zim-0.71.0.ebuild b/x11-misc/zim/zim-0.71.0.ebuild
new file mode 100644
index 000000000000..e9579e77339b
--- /dev/null
+++ b/x11-misc/zim/zim-0.71.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+inherit xdg-utils distutils-r1 gnome2-utils virtualx
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="
+ http://zim-wiki.org/
+ https://github.com/zim-desktop-wiki/
+"
+SRC_URI="https://github.com/${PN}-desktop-wiki/${PN}-desktop-wiki/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS=( CHANGELOG.md CONTRIBUTING.md PLUGIN_WRITING.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+S=${WORKDIR}/${PN}-desktop-wiki-${PV/_/-}
+
+python_prepare_all() {
+ sed -i -e "s/'USER'/'LOGNAME'/g" zim/__init__.py zim/fs.py || die
+
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Please install these packages for additional functionality"
+ elog " dev-lang/R"
+ elog " dev-python/gtkspell-python"
+ elog " dev-vcs/bzr"
+ elog " media-gfx/graphviz"
+ elog " media-gfx/imagemagick"
+ elog " media-gfx/scrot"
+ elog " media-sound/lilypond"
+ elog " sci-visualization/gnuplot"
+ elog " virtual/latex-base app-text/dvipng"
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}